aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-11 12:15:21 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-12 10:01:03 +0000
commitd19073b835c1dc3704d9b7366795d66be7f49862 (patch)
treee97a367fe888e40c59c69e073536d84d807d1394 /testing
parentb4382e8a2fa26e14f3b46f4fcf9d0acbefd19ce4 (diff)
downloadaports-d19073b835c1dc3704d9b7366795d66be7f49862.tar.bz2
aports-d19073b835c1dc3704d9b7366795d66be7f49862.tar.xz
testing/ansible-lint: bump to 4.1.0
- 4.1 was the first release to have a dependency upon ruamel.yaml - List all dependencies explicitly to match setup.cfg [1] - Stop using a parameter expansion that is not in POSIX: ${:0:1} - Switch to running the full test suite - setuptools is a runtime dependency because /usr/bin/ansible-lint uses 'from pkg_resources import load_entry_point' [1]: https://github.com/ansible/ansible-lint/blob/v4.1.0/setup.cfg#L82
Diffstat (limited to 'testing')
-rw-r--r--testing/ansible-lint/10-python3-shebang.patch8
-rw-r--r--testing/ansible-lint/APKBUILD17
2 files changed, 18 insertions, 7 deletions
diff --git a/testing/ansible-lint/10-python3-shebang.patch b/testing/ansible-lint/10-python3-shebang.patch
new file mode 100644
index 0000000000..1493a7a6a6
--- /dev/null
+++ b/testing/ansible-lint/10-python3-shebang.patch
@@ -0,0 +1,8 @@
+--- a/bin/ansible-lint
++++ b/bin/ansible-lint
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+
+ import sys
+ import ansiblelint.__main__
diff --git a/testing/ansible-lint/APKBUILD b/testing/ansible-lint/APKBUILD
index 4786a581ce..833fb6c586 100644
--- a/testing/ansible-lint/APKBUILD
+++ b/testing/ansible-lint/APKBUILD
@@ -1,15 +1,17 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=ansible-lint
-pkgver=3.4.23
+pkgver=4.1.0
pkgrel=0
pkgdesc="A tool to check ansible playbooks"
url="https://github.com/ansible/ansible-lint"
arch="noarch"
license="MIT"
-depends="ansible py3-six"
-makedepends="python3-dev py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+depends="ansible py3-yaml py3-six py3-ruamel.yaml py3-setuptools"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/a/$pkgname/$pkgname-$pkgver.tar.gz
+ 10-python3-shebang.patch
+ "
provides="py3-ansible-lint=$pkgver-r$pkgrel" # for backward compatibility
replaces="py3-ansible-lint" # for backward compatibility
@@ -24,8 +26,9 @@ package() {
}
check() {
- cd "$builddir/build/lib"
- python3 -c "import ansiblelint"
+ cd "$builddir"
+ python3 setup.py test
}
-sha512sums="b7754283943af88b8e11950b142bc36542c10d6f761a78f87d27954c62b70c77ae1d8925611d33f4daefc3c02d5fb217c419e3271eee33573a1cd48473bbf22d ansible-lint-3.4.23.tar.gz"
+sha512sums="320d0e544b2d0097f1a27b84d3abd0719096b643d77f0c920fdb07d3a40cc7fd967a36979c5a9700c53370ad86e516e35666a00224b2ca9661373de95dbc8106 ansible-lint-4.1.0.tar.gz
+4a8dbbc51f686985ba857aff4063c8f2078af4d9b4134d799017cca958d85e59e0f9985f8e1bb16c6e1110f2586119d33c31364e31722b343de15376e4a8dd2d 10-python3-shebang.patch"