aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSteve HOLWEG <skytep@gmail.com>2018-02-09 22:06:04 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-17 11:25:43 +0000
commite8dbf990a0d0da780f0be9a730c40cf02ce490a0 (patch)
tree3e1bf9bc5062053fbc012ac60810cfaccc949a77 /testing
parent2a240a88d3a5d9e763ed1d21148ddff1119b0c8a (diff)
testing/kea-hook-runscript: new aport
https://github.com/zorun/kea-hook-runscript This a hook for the Kea DHCP server that allows to run an external script.
Diffstat (limited to 'testing')
-rw-r--r--testing/kea-hook-runscript/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/kea-hook-runscript/APKBUILD b/testing/kea-hook-runscript/APKBUILD
new file mode 100644
index 00000000000..591c4799c0b
--- /dev/null
+++ b/testing/kea-hook-runscript/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Steve HOLWEG <skytep@gmail.com>
+
+pkgname=kea-hook-runscript
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="This a hook for the Kea DHCP server that allows to run an external script."
+arch="all"
+url="https://github.com/zorun/kea-hook-runscript"
+license="MPL2"
+depends="kea"
+makedepends="kea-dev kea-utils boost-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/zorun/$pkgname/archive/v$pkgver.tar.gz"
+options="!check" # Library and makefile provide no tests
+
+build() {
+ cd "$builddir"
+
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "${pkgdir}/usr/lib/hooks/"
+
+ install -Dm755 "kea-hook-runscript.so" "${pkgdir}/usr/lib/hooks/kea-hook-runscript.so"
+}
+
+sha512sums="b3b1c8ede6758b596fc03394bbd609aa7971d6b3bd267e2b5dda9c04ff6e9aa048de3d44e93ad287d70320784f1fcd101c03a9e8d12569403540fb49c32eda04 kea-hook-runscript-1.1.0.tar.gz"