aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-04-08 01:20:17 +0200
committerTBK <tbk@jjtc.eu>2020-04-08 10:16:25 +0000
commitea2bb75d3208ad4ca85fabc2a1872f0b1044d3f2 (patch)
tree89461e740ef6b1fb6d9ee66f551bb0cb2cf4ac4f /testing
parent6aa14031d1731960a7d8311746684cf4021e4d16 (diff)
testing/ponyc: upgrade to 0.33.2
Diffstat (limited to 'testing')
-rw-r--r--testing/ponyc/APKBUILD16
-rw-r--r--testing/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch25
2 files changed, 34 insertions, 7 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 3ea43809d98..26d02394ee1 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,23 +2,24 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=ponyc
-pkgver=0.33.0
+pkgver=0.33.2
pkgrel=0
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
-url="https://www.ponylang.org"
+url="https://www.ponylang.org/"
arch="all !s390x !ppc64le"
license="BSD-2-Clause"
-_llvmver=6
+_llvmver=9
depends="binutils-gold"
checkdepends="openssl-dev pcre2-dev"
-# Ponyc _is_ compatible with LLVM7, but LLVM7 is pretty buggy on musl.
makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark
zlib-dev linux-headers"
options="!check"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
source="ponyc-$pkgver.tar.gz::https://github.com/ponylang/ponyc/archive/$pkgver.tar.gz
more-portable-ln.patch
- makefile-remove-march-mtune.patch"
+ makefile-remove-march-mtune.patch
+ rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
+ "
export LLVM_CONFIG=/usr/lib/llvm$_llvmver/bin/llvm-config
# Required to not crash gold: https://sourceware.org/bugzilla/show_bug.cgi?id=23856
@@ -73,6 +74,7 @@ dev() {
mv "$pkgdir"/usr/lib/pony/$pkgver/include "$subpkgdir"/usr
}
-sha512sums="bc867af4334ca4aff5c4eefad9ac5ee3ea6027a4f021c5af4ae144a310f14c99207878ca24017face7c543bb7b4f8ee801c49d9368f5a3e6e7763abc5f867a6a ponyc-0.33.0.tar.gz
+sha512sums="cc02bdac029325689fbe7a5c9e8c9f8a8adf9346e17a6c626c9eca8dcae110c3cf4fb9af348b603e9804dff97183e02687f092d76b62e4bb13e571cd1c7585e8 ponyc-0.33.2.tar.gz
38aa40f6000dcb823be7b542cdad8d04b6ac4cd0a4fff1a472520a7cb71631fb34e5bee74914fe559674594dd901aede91390809e143dd96c5d68a16f8ac196c more-portable-ln.patch
-ce98aa2e33d057714703364509afd15e42ba53b5fefd42b66b9996a69036767595b868ddda592695bb109f09a7e1de118a53f262c2b23cbdf0b84063245f8b1b makefile-remove-march-mtune.patch"
+ce98aa2e33d057714703364509afd15e42ba53b5fefd42b66b9996a69036767595b868ddda592695bb109f09a7e1de118a53f262c2b23cbdf0b84063245f8b1b makefile-remove-march-mtune.patch
+1c59f43f8aae369a0fc05c23082e86562d46f943a54e7490d5cb4f5087096213b44d7bda7fde9a1a536536c6f40fa29b9a88b3ac6c0e8e1d33c4a38f9201bc90 rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch"
diff --git a/testing/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch b/testing/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
new file mode 100644
index 00000000000..d8b4ece8672
--- /dev/null
+++ b/testing/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
@@ -0,0 +1,25 @@
+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=45bdc66159d49bfc7f75fe02d25bc74f5d2660cf
+--- a/src/libponyrt/lang/socket.c
++++ b/src/libponyrt/lang/socket.c
+@@ -4470,8 +4470,8 @@
+ #ifdef SO_RCVLOWAT
+ case 886: return SO_RCVLOWAT;
+ #endif
+-#ifdef SO_RCVTIMEO
+- case 887: return SO_RCVTIMEO;
++#ifdef SO_RCVTIMEO_OLD
++ case 887: return SO_RCVTIMEO_OLD;
+ #endif
+ #ifdef SO_RDS_TRANSPORT
+ case 888: return SO_RDS_TRANSPORT;
+@@ -4527,8 +4527,8 @@
+ #ifdef SO_SNDLOWAT
+ case 905: return SO_SNDLOWAT;
+ #endif
+-#ifdef SO_SNDTIMEO
+- case 906: return SO_SNDTIMEO;
++#ifdef SO_SNDTIMEO_OLD
++ case 906: return SO_SNDTIMEO_OLD;
+ #endif
+ #ifdef SO_TIMESTAMP
+ case 907: return SO_TIMESTAMP;