aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-07 12:12:02 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 05:42:36 -0300
commitf69e5c19191bd098bded41798f6c2834930be85e (patch)
tree07a1690ba0c58436d73ddfa452322aaf4665123c /testing
parent321c84716168d43fb2fa046c3d691737a335bbb6 (diff)
community/ofono: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/ofono/APKBUILD43
-rw-r--r--testing/ofono/fix-TEMP_FAILURE_RETRY.patch21
-rw-r--r--testing/ofono/fix-explicit-bzero.patch16
-rw-r--r--testing/ofono/ofono.initd20
-rw-r--r--testing/ofono/skip-broken-test.patch12
5 files changed, 0 insertions, 112 deletions
diff --git a/testing/ofono/APKBUILD b/testing/ofono/APKBUILD
deleted file mode 100644
index 1619e09c118..00000000000
--- a/testing/ofono/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=ofono
-pkgver=1.31
-pkgrel=0
-pkgdesc="Infrastructure for building mobile telephony (GSM/UMTS) applications"
-url="https://01.org/ofono"
-arch="all"
-license="GPL-2.0-only"
-depends="bluez mobile-broadband-provider-info"
-makedepends="glib-dev dbus-dev eudev-dev
- linux-headers bsd-compat-headers libexecinfo-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
-source="https://www.kernel.org/pub/linux/network/ofono/ofono-$pkgver.tar.xz
- fix-explicit-bzero.patch
- fix-TEMP_FAILURE_RETRY.patch
- skip-broken-test.patch
- $pkgname.initd"
-
-build() {
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --sbindir=/usr/sbin
- make
-}
-
-check() {
- make -j1 check
-}
-
-package() {
- make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir"/$pkgname-$pkgver/plugins/ofono.rules "$pkgdir"/usr/lib/udev/rules.d/60-ofono.rules
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-
-sha512sums="377cda34dcc92d1f339a4b3271de5a14afaf309061c4467e5af18089cd821e65c0d8ad29d07e96d0f0480bb51554b284afb6bc2b9da586cc30dc0c1440612b20 ofono-1.31.tar.xz
-7367464a8983969c9a78c1e4f8759a17eb47f6c61c94b088d749c83bb7ef5d19e037cadedd7ef5d34a0fdfe837fa8059e963f4fb2b14148e4a80f00e7cb29286 fix-explicit-bzero.patch
-687a2fd592add40122b789073ab9970d6e966752fdecc4077afe1c1bba705fe541dd0e457094f1d9cde747c571b7810b5b1a30835a3f1869bcd810751d5bf76f fix-TEMP_FAILURE_RETRY.patch
-777ab2e13eebd1ccbe12a304310a83b262a5d934207c6a8d410e75aff380838eed1a52f3c2fe0d80c1e7db7faa9b55bf17e78a1e1acd8cfb95a3c6aef49c5b67 skip-broken-test.patch
-8bf14296d15458c930c99b97408fd6fb0d6d3cb9bffd5d85e7500514dc99fffe39a300da24ebc776811fe75e217a5537e358f72c3e8ac5070ec17f36bab086a9 ofono.initd"
diff --git a/testing/ofono/fix-TEMP_FAILURE_RETRY.patch b/testing/ofono/fix-TEMP_FAILURE_RETRY.patch
deleted file mode 100644
index 70df8c97026..00000000000
--- a/testing/ofono/fix-TEMP_FAILURE_RETRY.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/drivers/mbimmodem/mbim.c b/drivers/mbimmodem/mbim.c
-index 54b18ac..5f924ca 100644
---- a/drivers/mbimmodem/mbim.c
-+++ b/drivers/mbimmodem/mbim.c
-@@ -41,6 +41,15 @@
- #define HEADER_SIZE (sizeof(struct mbim_message_header) + \
- sizeof(struct mbim_fragment_header))
-
-+#ifndef TEMP_FAILURE_RETRY
-+#define TEMP_FAILURE_RETRY(expression) \
-+ (__extension__ \
-+ ({ long int __result; \
-+ do __result = (long int) (expression); \
-+ while (__result == -1L && errno == EINTR); \
-+ __result; }))
-+#endif
-+
- const uint8_t mbim_uuid_basic_connect[] = {
- 0xa2, 0x89, 0xcc, 0x33, 0xbc, 0xbb, 0x8b, 0x4f, 0xb6, 0xb0,
- 0x13, 0x3e, 0xc2, 0xaa, 0xe6, 0xdf
-
diff --git a/testing/ofono/fix-explicit-bzero.patch b/testing/ofono/fix-explicit-bzero.patch
deleted file mode 100644
index 855fa6ba760..00000000000
--- a/testing/ofono/fix-explicit-bzero.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/ell/missing.h b/ell/missing.h
-index 37d5586..649a5ac 100644
---- a/ell/missing.h
-+++ b/ell/missing.h
-@@ -54,11 +54,3 @@
- # define __NR_getrandom 0xffffffff
- # endif
- #endif
--
--#ifndef HAVE_EXPLICIT_BZERO
--static inline void explicit_bzero(void *s, size_t n)
--{
-- memset(s, 0, n);
-- __asm__ __volatile__ ("" : : "r"(s) : "memory");
--}
--#endif
diff --git a/testing/ofono/ofono.initd b/testing/ofono/ofono.initd
deleted file mode 100644
index ad555f63f5d..00000000000
--- a/testing/ofono/ofono.initd
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Purpose License v2
-# $Header: ./gentoo-x86-cvsroot/net-misc/ofono/files/ofono.initd,v 1.1 2009/08/24 13:20:40 dagger Exp $
-
-depend() {
- need dbus
-}
-
-start() {
- ebegin "Starting oFono"
- start-stop-daemon --start --quiet --exec /usr/sbin/ofonod
- eend $?
-}
-
-stop() {
- ebegin "Stopping oFono"
- start-stop-daemon --stop --quiet --exec /usr/sbin/ofonod
- eend $?
-}
diff --git a/testing/ofono/skip-broken-test.patch b/testing/ofono/skip-broken-test.patch
deleted file mode 100644
index baa65884283..00000000000
--- a/testing/ofono/skip-broken-test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/unit/test-stkutil.c b/unit/test-stkutil.c.new
-index c595ac1c03..38e9455ba3 100644
---- a/unit/test-stkutil.c
-+++ b/unit/test-stkutil.c.new
-@@ -313,6 +313,7 @@ static inline void check_tone(const ofono_bool_t command,
- static inline void check_ussd(const struct stk_ussd_string *command,
- const char *test)
- {
-+ return; // Test currently broken
- char *utf8 = ussd_decode(command->dcs, command->len, command->string);
- check_common_text(utf8, test);
- g_free(utf8);