aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 18:53:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-30 18:53:28 -0300
commitfd441db85253ec39908341e5264b7461bcb9ff56 (patch)
tree38c9f8ae589f17da389f528523ea6b56c2c43d62 /testing
parent661fec13dc7c89656e1fae9ac58130f492b95fac (diff)
testing/ffsend: disable stack-protector for backtrace-sys
Diffstat (limited to 'testing')
-rw-r--r--testing/ffsend/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/ffsend/APKBUILD b/testing/ffsend/APKBUILD
index 0722846a782..3179b97d0e3 100644
--- a/testing/ffsend/APKBUILD
+++ b/testing/ffsend/APKBUILD
@@ -11,6 +11,12 @@ makedepends="cargo openssl-dev"
source="https://gitlab.com/timvisee/ffsend/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
+case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+esac
+
build() {
cargo build --release
}