aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-13 10:19:03 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-13 10:20:25 +0000
commitfe569ef05ee26452a669c13768bcd16bbc43d82e (patch)
tree6dfe8e2ad0e215e3a182bdc2ec508a6ddfe42ca1 /testing
parent7c3c6c9d9ce0c95cfa925212bc9f11916d91a68d (diff)
testing/cni-plugins: fix build on x86
Fail build on x86: github.com/safchain/ethtool/ethtool.go:205:35: undefined: syscall.SYS_SOCKET Applied patch as described here: https://github.com/safchain/ethtool/pull/16
Diffstat (limited to 'testing')
-rw-r--r--testing/cni-plugins/APKBUILD6
-rw-r--r--testing/cni-plugins/ethtool-x86-go.patch17
2 files changed, 21 insertions, 2 deletions
diff --git a/testing/cni-plugins/APKBUILD b/testing/cni-plugins/APKBUILD
index f2a4738d48a..c8e3b05d293 100644
--- a/testing/cni-plugins/APKBUILD
+++ b/testing/cni-plugins/APKBUILD
@@ -9,7 +9,8 @@ arch="all"
license="Apache"
makedepends="go bash linux-headers"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/containernetworking/plugins/archive/v${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/containernetworking/plugins/archive/v${pkgver}.tar.gz
+ethtool-x86-go.patch"
builddir="$srcdir/plugins-$pkgver"
build() {
@@ -29,4 +30,5 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-sha512sums="de685a66e0e875e8a2209b76c5d1f5fd0e426804e3db6084cf2e89695a8b1876eae47ff1fcfdf065a3b027918fe7c4775d2321358402dbd1206928538edb52b4 cni-plugins-0.8.0.tar.gz"
+sha512sums="de685a66e0e875e8a2209b76c5d1f5fd0e426804e3db6084cf2e89695a8b1876eae47ff1fcfdf065a3b027918fe7c4775d2321358402dbd1206928538edb52b4 cni-plugins-0.8.0.tar.gz
+f247f36d1c0ef6d5022f217dd6a6cc09c92211fe060077d8dc7df4a391b7db13a73cd4edb039c9539f735d6d9c4cde93ee8592d566efa4a3ed216bdbabfd96a1 ethtool-x86-go.patch"
diff --git a/testing/cni-plugins/ethtool-x86-go.patch b/testing/cni-plugins/ethtool-x86-go.patch
new file mode 100644
index 00000000000..00f2798b9d6
--- /dev/null
+++ b/testing/cni-plugins/ethtool-x86-go.patch
@@ -0,0 +1,17 @@
+diff --git a/vendor/github.com/safchain/ethtool/ethtool.go b/vendor/github.com/safchain/ethtool/ethtool.go
+index 1f8828f..98387e6 100644
+--- a/vendor/github.com/safchain/ethtool/ethtool.go
++++ b/vendor/github.com/safchain/ethtool/ethtool.go
+@@ -202,9 +202,9 @@ func (e *Ethtool) Close() {
+ }
+
+ func NewEthtool() (*Ethtool, error) {
+- fd, _, err := syscall.RawSyscall(syscall.SYS_SOCKET, syscall.AF_INET, syscall.SOCK_DGRAM, syscall.IPPROTO_IP)
+- if err != 0 {
+- return nil, syscall.Errno(err)
++ fd, err := syscall.Socket(syscall.AF_INET, syscall.SOCK_DGRAM, syscall.IPPROTO_IP)
++ if err != nil {
++ return nil, err
+ }
+
+ return &Ethtool{