aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ntopng
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-02 10:06:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-02 10:06:06 +0000
commit7c6239b112238719c308c1640f9cf50fcf44a148 (patch)
tree211cd3a4cb82eaaaae51d3ba900f6cbff0952c2a /unmaintained/ntopng
parent8567007f74e878fb8abc7c43b0f887f4fda372b7 (diff)
testing/ntopng: move to unmaintained
Diffstat (limited to 'unmaintained/ntopng')
-rw-r--r--unmaintained/ntopng/APKBUILD66
-rw-r--r--unmaintained/ntopng/ntopng-update-geoip-db25
-rw-r--r--unmaintained/ntopng/ntopng.confd8
-rw-r--r--unmaintained/ntopng/ntopng.initd26
-rwxr-xr-xunmaintained/ntopng/ntopng.pre-install6
5 files changed, 131 insertions, 0 deletions
diff --git a/unmaintained/ntopng/APKBUILD b/unmaintained/ntopng/APKBUILD
new file mode 100644
index 00000000000..5a984c6ab4f
--- /dev/null
+++ b/unmaintained/ntopng/APKBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=ntopng
+pkgver=2.4
+pkgrel=4
+pkgdesc="ntop next-generation"
+url="http://www.ntop.org"
+# luajit is not available for disabled arches
+arch="all !s390x"
+license="GPL"
+depends=
+pkgusers="ntop"
+pkggroups="ntop"
+makedepends="autoconf automake curl-dev geoip-dev glib-dev hiredis-dev
+ libpcap-dev libtool libxml2-dev lua-dev luajit-dev lua-redis libressl-dev
+ paxmark rrdtool-dev sqlite-dev wget zeromq-dev zlib-dev
+ linux-headers mariadb-connector-c-dev"
+install="$pkgname.pre-install"
+#subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/project/ntop/$pkgname/$pkgname-$pkgver-stable.tar.gz
+ $pkgname.initd
+ $pkgname.confd
+ ntopng-update-geoip-db
+
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver-stable
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make all || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" MAN_DIR="$pkgdir/usr/share" install || return 1
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D "$srcdir"/ntopng-update-geoip-db \
+ "$pkgdir"/usr/bin/ntopng-update-geoip-db
+ # ntop internal db dir
+ install -d -o ntop -g ntop -m755 "$pkgdir"/var/lib/ntopng/geoip || return 1
+ install -d -o ntop -g ntop -m755 "$pkgdir"/var/run/ntopng || return 1
+ # need to disable PAX mprotect protection for luajit
+ paxmark -m "$pkgdir"/usr/bin/$pkgname || return 1
+}
+
+sha512sums="515dd7889ae3aaf2482371bb2c55ab7300cf4207fe07f37029b7529bfb710379c19a54f58cf6df87e42454c0c99d15291af334adff676252301d9edd0acf3c7a ntopng-2.4-stable.tar.gz
+b7924953953470971e67e463260514c30a4a3038ecbb642aec1ad66d12b5af76bdda56c99de675a1fbb106664fa0e3779a4f35fdeedc94d65af486053b7650e1 ntopng.initd
+bbe7a15e0aec59f12264f39bf33abb67a12b76adac3a6554fcf1e21849aea06fce1e0c0d9831836bd46105a5cc4b3eb780866934d8711386e1cb1218dbdbbe8b ntopng.confd
+de509706c36e895159b4e57b5fe53f1fa8f32167416aad5fa391ac107f0e7e1a06fa5ce6d92816ef7cb13bf98bb74cb99fa482d03f77a6beb38eafe1d53d2deb ntopng-update-geoip-db"
diff --git a/unmaintained/ntopng/ntopng-update-geoip-db b/unmaintained/ntopng/ntopng-update-geoip-db
new file mode 100644
index 00000000000..1ac05bc0e03
--- /dev/null
+++ b/unmaintained/ntopng/ntopng-update-geoip-db
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+BASE_URL=http://geolite.maxmind.com/download/geoip/database
+
+echo "Updating NTOP GeoIP databases..."
+
+cd /usr/share/ntopng/geoip || exit
+
+for u in \
+ asnum/GeoIPASNum.dat.gz \
+ asnum/GeoIPASNumv6.dat.gz \
+ GeoLiteCity.dat.gz \
+ GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; do
+ FILE_GZ=${u#*/}
+ FILE=${FILE_GZ%.gz}
+ wget -O ${FILE_GZ} ${BASE_URL}/${u} &&
+ gunzip < ${FILE_GZ} > .${FILE} &&
+ mv -f .${FILE} ${FILE} &&
+ rm -f ${FILE_GZ} ||
+ exit
+done
+
+rc-service ntopng status && rc-service ntopng restart
+
+echo "NTOP GeoIP databases were successfully updated"
diff --git a/unmaintained/ntopng/ntopng.confd b/unmaintained/ntopng/ntopng.confd
new file mode 100644
index 00000000000..4d11cffe8ab
--- /dev/null
+++ b/unmaintained/ntopng/ntopng.confd
@@ -0,0 +1,8 @@
+### Default options for ntopng
+
+# pidfile="/var/run/ntopng/ntopng.pid"
+# exec_user=ntop
+# command_args="--daemon --data-dir /var/lib/ntopng --httpdocs-dir /usr/share/ntopng/httpdocs --pid $pidfile -U $exec_user"
+
+### Additional options here
+NTOPNG_OPTS=""
diff --git a/unmaintained/ntopng/ntopng.initd b/unmaintained/ntopng/ntopng.initd
new file mode 100644
index 00000000000..c625b2ca466
--- /dev/null
+++ b/unmaintained/ntopng/ntopng.initd
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+
+depend() {
+ need net
+ use redis
+}
+
+command="/usr/bin/ntopng"
+pidfile="/var/run/ntopng/ntopng.pid"
+: ${exec_user:=ntop}
+: ${command_args:="--daemon --data-dir /var/lib/ntopng --httpdocs-dir /usr/share/ntopng/httpdocs --pid $pidfile -U $exec_user $NTOPNG_OPTS"}
+
+checkconfig() {
+ if [ ! -e /usr/share/ntopng/httpdocs/geoip/GeoIPASNum.dat ] || \
+ [ ! -e /usr/share/ntopng/httpdocs/geoip/GeoLiteCity.dat ]; then
+ eerror "You need download the GeoIP database"
+ eerror "ntopng-update-geoip-db"
+ return 1
+ fi
+}
+
+prestart() {
+ checkconfig || return 1
+ eend $?
+}
+
diff --git a/unmaintained/ntopng/ntopng.pre-install b/unmaintained/ntopng/ntopng.pre-install
new file mode 100755
index 00000000000..0fea81baa7b
--- /dev/null
+++ b/unmaintained/ntopng/ntopng.pre-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+addgroup -S ntop 2>/dev/null
+adduser -S -D -H -h /var/lib/ntop -s /sbin/nologin -G ntop -g ntop ntop 2>/dev/null
+
+exit 0