aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2017-12-25 00:00:37 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-26 11:45:53 +0000
commitdac21535559575c800cad79280a231e559162cda (patch)
tree0c539dca2e0449b20acafd0130a3d4b196d05eb1 /unmaintained
parent66dad3c936ed7965770b140c69f18ada4c69efe9 (diff)
unmaintained/py3-hypothesis: move from testing
They release about twice a week, we can't keep up with this.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py3-hypothesis/APKBUILD29
-rw-r--r--unmaintained/py3-hypothesis/check.py6
2 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/py3-hypothesis/APKBUILD b/unmaintained/py3-hypothesis/APKBUILD
new file mode 100644
index 00000000000..9f428cd7f74
--- /dev/null
+++ b/unmaintained/py3-hypothesis/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=py3-hypothesis
+pkgver=3.28.3
+pkgrel=0
+pkgdesc="Hypothesis is an advanced testing library for Python"
+url="http://hypothesis.works/"
+arch="noarch"
+license="MPL"
+depends="python3 py3-attrs"
+makedepends="python3-dev py3-pytest"
+source="py3-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/$pkgver.tar.gz"
+builddir="$srcdir/hypothesis-python-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$builddir/src" pytest-3 check.py
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="402f116c215af4b57f9702b6af716f0b43a0dd8ee75dc609a0c430fb516dccbab57b438a58590259b25e1bbefaae05dfb28eec80242c599864bc352b98b269b5 py3-hypothesis-3.28.3.tar.gz"
diff --git a/unmaintained/py3-hypothesis/check.py b/unmaintained/py3-hypothesis/check.py
new file mode 100644
index 00000000000..1250548c7dd
--- /dev/null
+++ b/unmaintained/py3-hypothesis/check.py
@@ -0,0 +1,6 @@
+from hypothesis import given
+from hypothesis.strategies import text
+
+@given(s=text())
+def test_decode_inverts_encode(s):
+ assert s.encode("UTF").decode("UTF-8") == s