summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-26 13:08:33 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-26 13:08:33 +0100
commit218fa3fba584772fb9275cd335aac1639ab72445 (patch)
treef49c76d699b5b133e32bea7fc7cd164164225c92 /unmaintained
parent3b96db9e41611b61d7df6ffd57c5c72135f2df0b (diff)
testing/corosync: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/corosync/APKBUILD61
-rw-r--r--unmaintained/corosync/corosync.initd23
2 files changed, 84 insertions, 0 deletions
diff --git a/unmaintained/corosync/APKBUILD b/unmaintained/corosync/APKBUILD
new file mode 100644
index 00000000000..7a3c050072a
--- /dev/null
+++ b/unmaintained/corosync/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=corosync
+pkgver=2.3.2
+pkgrel=0
+pkgdesc="The Corosync Cluster Engine and Application Programming Interfaces"
+url="http://www.corosync.org/"
+arch="all"
+license="BSD2"
+depends=""
+depends_dev="nss-dev net-snmp-dev"
+makedepends="$depends_dev libqb-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://build.clusterlabs.org/corosync/releases/corosync-$pkgver.tar.gz
+ $pkgname.initd"
+_builddir="$srcdir"/corosync-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-snmp \
+ --enable-nss \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+}
+
+libs() {
+ pkgdesc="The Corosync Cluster Engine Libraries"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/ || return 1
+}
+
+md5sums="0471219664186d110273b8ce48b1d169 corosync-2.3.2.tar.gz
+4d18555dfdd036b7a48eb5bdfd0ff053 corosync.initd"
+sha256sums="0721b90e095d56e95bee3fde77da6f596dc95ec856b404e1fdb9b4f9013d99fa corosync-2.3.2.tar.gz
+8e5a18febe55a08b8b5be80ca2e3b81cdf961784d7a2f246b9064825d3a847bc corosync.initd"
+sha512sums="b3f90da98fb0e0de632ccf9ba850aa8c3d1015bbc0ea81234f4284e2c793bc67642049bfa37e9c1ef6e91f28a3e0a3ad4fb4378cb7911ed67b1e807c63b3e846 corosync-2.3.2.tar.gz
+be5ec458f8eb234eb01ba1023e59b35f967f0833fd8097eb8f9b5e9d172fe3beffc6ea3d15dd57f1b76ab7b90cdfccdb4868962488d4af573e70c55baf021a65 corosync.initd"
diff --git a/unmaintained/corosync/corosync.initd b/unmaintained/corosync/corosync.initd
new file mode 100644
index 00000000000..6c134bd9377
--- /dev/null
+++ b/unmaintained/corosync/corosync.initd
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/files/corosync.initd,v 1.2 2010/11/17 07:07:03 xarthisius Exp $
+
+depend() {
+ need net
+ use logger
+}
+
+start() {
+ ebegin "Starting Corosync Cluster Engine"
+ start-stop-daemon --start -q --exec /usr/sbin/corosync \
+ --pidfile /var/run/corosync.pid --make-pidfile --background \
+ -- -f
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Corosync Cluster Engine"
+ start-stop-daemon --stop -q --pidfile /var/run/corosync.pid
+ eend $?
+}