aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-05-11 20:56:42 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-11 20:56:42 +0000
commit199296e63294be05bd25c20e8e648e8817fc0272 (patch)
treebba47b976e53f3bd32094a4afa4b53eccf5a000c /unmaintained
parent307c5c8a2103c8df5728af51929d622f1c22761d (diff)
unmaintained/deafbeef: move from community
Package does not build and has no maintainer. There are not packages depending on it.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/deadbeef/APKBUILD39
-rw-r--r--unmaintained/deadbeef/strdupa.patch17
-rw-r--r--unmaintained/deadbeef/use-endian-h.patch11
3 files changed, 67 insertions, 0 deletions
diff --git a/unmaintained/deadbeef/APKBUILD b/unmaintained/deadbeef/APKBUILD
new file mode 100644
index 00000000000..a1eee6cb123
--- /dev/null
+++ b/unmaintained/deadbeef/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Contributor:
+# Maintainer:
+pkgname=deadbeef
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="fairly capable playlist-oriented audio player"
+url="http://deadbeef.sourceforge.net/"
+arch="all"
+license="Zlib GPL-2.0-or-later LGPL-2.1-or-later"
+depends="desktop-file-utils hicolor-icon-theme"
+depends_dev="gtk+3.0-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev
+ gettext-dev flac-dev libvorbis-dev jansson-dev curl-dev opusfile-dev
+ libsndfile-dev"
+makedepends="$depends_dev intltool gettext bsd-compat-headers"
+subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ strdupa.patch
+ use-endian-h.patch"
+options="!check"
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-oss \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c39fc34bcd70ac745ce9c5ac6f4f4535d07d47906dd297bc598e850178e46ab8e933cd11e04e71b9432462c7a1e36f4a8ead3a50f0bb15a696c3961c336611ad deadbeef-1.8.0.tar.bz2
+902c65cc5fd39f9935080a7f5df6d7c17fb366706501957a6b54d796f1b7b64a03fed64f93c9149d9332c4638de35254d526c031af0cd12674efb8d25dff31e1 strdupa.patch
+9d933a33c6d78d66d4b6cb448aaeaf60b79e6269ce1c48e314b135f79779cdeb4e541b4c10c8666010b488e10108d0154a84835115933a8c6677f066044a1197 use-endian-h.patch"
diff --git a/unmaintained/deadbeef/strdupa.patch b/unmaintained/deadbeef/strdupa.patch
new file mode 100644
index 00000000000..dd0a60c17d1
--- /dev/null
+++ b/unmaintained/deadbeef/strdupa.patch
@@ -0,0 +1,17 @@
+musl strdupa() fails to compile in c++ due to a missing cast
+use deadbeef's fallback version instead
+
+--- a/strdupa.h
++++ b/strdupa.h
+@@ -26,6 +26,10 @@
+
+ #include <string.h>
+
++#if defined(__linux__) && !defined(__GLIBC__)
++# undef strdupa
++#endif
++
+ #ifndef strdupa
+ # define strdupa(s) \
+ ({ \
+
diff --git a/unmaintained/deadbeef/use-endian-h.patch b/unmaintained/deadbeef/use-endian-h.patch
new file mode 100644
index 00000000000..a8829dcb84d
--- /dev/null
+++ b/unmaintained/deadbeef/use-endian-h.patch
@@ -0,0 +1,11 @@
+--- a/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
++++ b/plugins/gme/game-music-emu-0.6pre/gme/blargg_endian.h
+@@ -21,7 +21,7 @@
+ // BLARGG_BIG_ENDIAN, BLARGG_LITTLE_ENDIAN: Determined automatically, otherwise only
+ // one may be #defined to 1. Only needed if something actually depends on byte order.
+ #if !defined (BLARGG_BIG_ENDIAN) && !defined (BLARGG_LITTLE_ENDIAN)
+-#if defined(__BYTE_ORDER) && defined(__LITTLE_ENDIAN) && defined(__BIG_ENDIAN)
++#ifdef __linux__
+ // GCC handles this for us
+ #include <endian.h>
+ #if __BYTE_ORDER == __LITTLE_ENDIAN