aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 13:58:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 14:26:33 -0300
commit2dc9f0dd4cef783846ffa8e272141386a64840e2 (patch)
tree0f0b751d4d80da4b64ddb0dc9d023673debfcad2 /unmaintained
parenta6343f1809216f87a3255a3fcf212c68b6da3a35 (diff)
unmaintained/py-flask-errormail: move from testing
- Python2 only - Development is frozen
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-flask-errormail/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-flask-errormail/APKBUILD b/unmaintained/py-flask-errormail/APKBUILD
new file mode 100644
index 00000000000..24cbe619646
--- /dev/null
+++ b/unmaintained/py-flask-errormail/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-errormail
+_pkgname=Flask-ErrorMail
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Flask sending error mail extension"
+url="https://pypi.python.org/pypi/Flask-ErrorMail"
+arch="noarch"
+license="MIT"
+depends="python2 py-flask"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4deaf797b70de3f45ce5a06270952b8a Flask-ErrorMail-0.2.2.tar.gz"
+sha256sums="e4886e5e1ef630c5b6b958856dff6f80545f5acaa2530586a00466d8a6fab41c Flask-ErrorMail-0.2.2.tar.gz"
+sha512sums="fc9fdb749cdbd7ba32ca8454709f10d6f30c98d64a0e1ff179e5f00dc0564e8506d004a95c2603e95cc39e0dc9ce666dc63c5e6b36bcb6c00f3033599f750226 Flask-ErrorMail-0.2.2.tar.gz"