aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-17 08:43:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:58 +0000
commit9560225c584c41f97e94845e5a8c9504fe40cc86 (patch)
treef47fbd9cae308c58fad91253e26f9f94e068ffd7 /unmaintained
parentd96761137c878ce2b9a9047bd08231d5192093d2 (diff)
testing/py-weasyprint: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-weasyprint/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/unmaintained/py-weasyprint/APKBUILD b/unmaintained/py-weasyprint/APKBUILD
new file mode 100644
index 00000000000..364466c78eb
--- /dev/null
+++ b/unmaintained/py-weasyprint/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor:
+# Maintainer:
+pkgname=py-weasyprint
+_pkgname=WeasyPrint
+pkgver=0.42.3
+pkgrel=0
+pkgdesc="cairo-based HTML renderer for python"
+url="http://weasyprint.org"
+arch="noarch"
+license="LGPL"
+depends="pango cairo py-cairocffi py-cairosvg py-cssselect py-tinycss py-pyphen py-lxml"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2-dev python3-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py3
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ cd "$builddir"-py3
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ cd "$builddir"-py3
+ python3 setup.py check
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ cd "$builddir"
+ _py python2
+}
+
+_py3() {
+ cd "$builddir"-py3
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="d6007934c301904308bd4821626d6a7bb504268c5c71a31f7486faebb3dd649fad18774737cab39eb13a0916635bb58eba2c8432c72cc5a461cea2a5d874b1ee WeasyPrint-0.42.3.tar.gz"