aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-09 23:09:06 +0300
committerprspkt <prspkt@protonmail.com>2019-06-09 23:09:06 +0300
commit9f5e3b8941c604baada637eeec3e4ea4d4cf6671 (patch)
tree25a824bbbd79fb7247ea05e857a8815069c87dc4 /unmaintained
parent35f5c5ddb68952d90144ee2e5e6d011d77deeb64 (diff)
testing/nicotine-plus: move to unmaintained
- Python2 only, at least for now. - Broken due to unsatisfied runtime dependencies.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/nicotine-plus/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/unmaintained/nicotine-plus/APKBUILD b/unmaintained/nicotine-plus/APKBUILD
new file mode 100644
index 00000000000..3b1ee65ea51
--- /dev/null
+++ b/unmaintained/nicotine-plus/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=nicotine-plus
+pkgver=1.4.1
+pkgrel=0
+pkgdesc="Graphical client for the SoulSeek peer-to-peer system"
+url="http://nicotine-plus.org"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="librsvg py-gtk py-mutagen"
+subpackages="$pkgname-doc $pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Nicotine-Plus/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="894dfb318b205b6be21face0308f183da15772f329158c6a9a8a816dfdf231ad89245188acad5538821b2a778c8a8a6201ce8548cc58550c4eb6c0763db9d66a nicotine-plus-1.4.1.tar.gz"