aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-16 18:54:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:55 +0000
commitf6d447ce3033aa0d5ad76b04e0fe4b7f05db94e0 (patch)
tree91078aaeae3451928906fc374f68f82ec95a6bcf /unmaintained
parent6a62bd791083a679fdbcac339ae847d10018aa13 (diff)
testing/py3-llfuse: move to unmaintained
no longer maintained upstream.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py3-llfuse/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/py3-llfuse/APKBUILD b/unmaintained/py3-llfuse/APKBUILD
new file mode 100644
index 00000000000..9b2ec7fd648
--- /dev/null
+++ b/unmaintained/py3-llfuse/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+# TODO: Add check (needs pytest-checklog).
+pkgname=py3-llfuse
+_pkgname=llfuse
+pkgver=1.3.2
+pkgrel=0
+pkgdesc="Python bindings for the low-level FUSE API"
+url="https://bitbucket.org/nikratio/python-llfuse/"
+arch="all"
+license="LGPL"
+makedepends="python3-dev fuse-dev attr-dev"
+checkdepends="pytest"
+source="https://bitbucket.org/nikratio/python-llfuse/downloads/$_pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f065818134b12dd128574836bc7d339404d9b7d9236b535da709378e9206b17cb2accd97fc0b658f39a93efe126a7c3064f7901468231f63f8398a3e053498cf llfuse-1.3.2.tar.bz2"