summaryrefslogtreecommitdiffstats
path: root/unstable
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-04-08 12:40:15 +0000
committerMichael Mason <ms13sp@gmail.com>2009-04-08 12:40:15 +0000
commita40b0c5183de5b010a2b680ab54ad22f38281072 (patch)
treebf44359b9a105c1cf7bb132e07df6549a565872b /unstable
parent4ec779eec44bc07e4e48b85fa97766fe06999c22 (diff)
unstable/ucarp Updated confd initd
Diffstat (limited to 'unstable')
-rw-r--r--unstable/ucarp/APKBUILD4
-rw-r--r--unstable/ucarp/ucarp.confd3
-rwxr-xr-x[-rw-r--r--]unstable/ucarp/ucarp.initd5
3 files changed, 8 insertions, 4 deletions
diff --git a/unstable/ucarp/APKBUILD b/unstable/ucarp/APKBUILD
index fe3afce0dd4..ed35064f112 100644
--- a/unstable/ucarp/APKBUILD
+++ b/unstable/ucarp/APKBUILD
@@ -29,5 +29,5 @@ build() {
}
md5sums="ba585233e73f0dbce80427d04f431048 ucarp-1.5.tar.gz
-fae5ca64ed20a9346b00e9c9411a43c8 ucarp.initd
-ffdbc07da100b4882cc5da9121c0c842 ucarp.confd"
+e8f1e2fd144797524025343603dbe2b8 ucarp.initd
+bf914f6ce4fe4fea33a45d4d5b2c1fff ucarp.confd"
diff --git a/unstable/ucarp/ucarp.confd b/unstable/ucarp/ucarp.confd
index 86b501c3980..824358b430e 100644
--- a/unstable/ucarp/ucarp.confd
+++ b/unstable/ucarp/ucarp.confd
@@ -3,8 +3,11 @@
# VHID - Virtual Server ID
# VIP - The Virtual IP
# PASSWORD - The password for the carp announcements
+# EXTRA_ARGS - extra arguments
REALIP=
VHID=2
VIP=127.0.0.1
PASSWORD=SecretPassword
+#EXTRA_ARGS="--neutral --advbase=3"
+
diff --git a/unstable/ucarp/ucarp.initd b/unstable/ucarp/ucarp.initd
index b924f3b54f0..d03329fcb3e 100644..100755
--- a/unstable/ucarp/ucarp.initd
+++ b/unstable/ucarp/ucarp.initd
@@ -11,7 +11,7 @@ IFACE="${SVCNAME#*.}"
if [ -n "$IFACE" ] && [ "${SVCNAME}" != "ucarp" ]; then
UP="/etc/ucarp/vip-up-$IFACE.sh"
DOWN="/etc/ucarp/vip-down-$IFACE.sh"
- . /etc/ucarp/$IFACE.conf
+ . /etc/conf.d/ucarp.$IFACE
else
UP="/etc/ucarp/vip-up.sh"
DOWN="/etc/ucarp/vip-down.sh"
@@ -35,7 +35,7 @@ start () {
start-stop-daemon --start --exec $DAEMON \
--background -m -p /var/run/ucarp-$IFACE.pid -- \
-i $IFACE -s $REALIP -v $VHID -p $PASSWORD -a $VIP \
- -u $UP -d $DOWN -z
+ -u $UP -d $DOWN $EXTRA_ARGS -z
eend $?
}
@@ -60,3 +60,4 @@ stop () {
[ $? -eq 0 ] && rm /var/run/ucarp-$IFACE.pid
eend $?
}
+