summaryrefslogtreecommitdiffstats
path: root/x11/exo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-21 21:35:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-21 21:35:31 +0000
commit20c888446e995928d38d6ef7fc6f5096cd62445c (patch)
tree442b8752222064a68f6a0eebb2e5c74621572a17 /x11/exo
parente0788481ff05349cd747699886f6a14e1fe4f959 (diff)
x11/exo: new aport
Extensions to Xfce by os-cillation http://www.os-cillation.com/article.php?sid=40
Diffstat (limited to 'x11/exo')
-rw-r--r--x11/exo/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11/exo/APKBUILD b/x11/exo/APKBUILD
new file mode 100644
index 00000000000..bb51c9f02d3
--- /dev/null
+++ b/x11/exo/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# TODO: libnotify hal
+pkgname=exo
+pkgver=0.3.101
+pkgrel=0
+pkgdesc="Extensions to Xfce by os-cillation"
+url="http://www.os-cillation.com/article.php?sid=40"
+license="GPL-2 LGPL-2"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libxfce4util hicolor-icon-theme gtk+ gettext libiconv uclibc"
+makedepends="intltool libxfce4util-dev perl perl-uri gtk+-dev gettext-dev
+ libiconv-dev"
+install=
+source="http://www.xfce.org/archive/xfce-4.6.1/src/$pkgname-$pkgver.tar.bz2"
+
+depends_dev="gtk+-dev libxfce4util-dev"
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-python \
+ --enable-notifications \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="1c0eebb360f53eab70454b70e1bde36e exo-0.3.101.tar.bz2"