summaryrefslogtreecommitdiffstats
path: root/x11/parole/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-15 20:01:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-15 20:01:26 +0000
commit4610d7f622982018b0f5c5c21f967f6dd2e4f1c7 (patch)
tree887b220ce5e331770f5b543cfd8d065fc410eb87 /x11/parole/APKBUILD
parent6a78b7dc84ef439e3fad1aca995fd25ad1b4d5c7 (diff)
x11/parole: new aport
Media player for the Xfce desktop http://goodies.xfce.org/projects/applications/parole/
Diffstat (limited to 'x11/parole/APKBUILD')
-rw-r--r--x11/parole/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11/parole/APKBUILD b/x11/parole/APKBUILD
new file mode 100644
index 00000000000..89b5c53b1e1
--- /dev/null
+++ b/x11/parole/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=parole
+pkgver=0.1.90
+pkgrel=0
+pkgdesc="Media player for the Xfce desktop"
+url="http://goodies.xfce.org/projects/applications/parole/"
+license="GPL"
+depends=""
+makedepends="libxfcegui4-dev libxfce4util-dev intltool gstreamer-dev
+ gst-plugins-base-dev libsm-dev taglib-dev libnotify-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://archive.xfce.org/src/apps/parole/${pkgver%.*}/parole-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="acf9085b49cf41469ce41076e6915253 parole-0.1.90.tar.bz2"