aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qemu/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-20 20:06:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-20 20:06:05 +0000
commit6e4e1290fc2ca97f39c013eb09baa1b603ab7132 (patch)
tree9635933a103937258a1620afc833f167e427b76e /x11/qemu/APKBUILD
parentbdf465055fb897d3b904e176719b2c8a0f0551bb (diff)
x11/qemu: new aport
QEMU is a generic machine emulator and virtualizer http://www.nongnu.org/qemu/
Diffstat (limited to 'x11/qemu/APKBUILD')
-rw-r--r--x11/qemu/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11/qemu/APKBUILD b/x11/qemu/APKBUILD
new file mode 100644
index 00000000000..7cacc742da3
--- /dev/null
+++ b/x11/qemu/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qemu
+pkgver=0.10.6
+pkgrel=0
+pkgdesc="QEMU is a generic machine emulator and virtualizer"
+url="http://www.nongnu.org/qemu/"
+license="GPL-2 LGPL-2"
+makedepends="sdl-dev alsa-lib-dev gnutls-dev"
+depends=
+install="qemu.pre-install"
+source="http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz
+ qemu-0.10.3-nopl-fix.patch"
+
+build()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ # avoid fdt till an updated release appears
+ sed -i -e 's:fdt="yes":fdt="no":' configure
+ # prevent docs to get automatically installed
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ # Alter target makefiles to accept CFLAGS
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ patch -p0 -i ../qemu-0.10.3-nopl-fix.patch || return 1
+ export CFLAGS="$CFLAGS -fno-pie -fno-stack-protector"
+
+ ./configure --prefix=/usr \
+ --audio-drv-list=oss,alsa,sdl \
+ --audio-card-list=ac97,sb16,es1370,adlib \
+ --disable-darwin-user \
+ --disable-bsd-user \
+ --disable-kqemu \
+ --cc="$CC"
+
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="e28f4b2d6faef178da44c03224feecb6 qemu-0.10.6.tar.gz
+aef31109b7cde6e31b9dac37c3f8a033 qemu-0.10.3-nopl-fix.patch"