summaryrefslogtreecommitdiffstats
path: root/x11/setxkbmap/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-16 19:56:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-16 19:56:52 +0000
commitaaa034b0e28a2947274d06dcd1ffb4c98421dad3 (patch)
tree2952ef0712aa103f612ae3d5cb65d77023a319ea /x11/setxkbmap/APKBUILD
parentb1aa63bbcc26e272aedc0b1097728d3d599b907e (diff)
x11/setxkbmap: new aport
set the keyboard using the X Keyboard Extension http://xorg.freedesktop.org/
Diffstat (limited to 'x11/setxkbmap/APKBUILD')
-rw-r--r--x11/setxkbmap/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/x11/setxkbmap/APKBUILD b/x11/setxkbmap/APKBUILD
new file mode 100644
index 00000000000..2b8eb19b696
--- /dev/null
+++ b/x11/setxkbmap/APKBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=setxkbmap
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="set the keyboard using the X Keyboard Extension"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends=
+makedepends="pkgconfig libxkbfile-dev"
+source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=""$pkgdir"" install || return 1
+}
+md5sums="2f902e0a89aaf2b19e06e7f26c6efb3a setxkbmap-1.1.0.tar.bz2"