aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/rcon/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/rcon/APKBUILD b/testing/rcon/APKBUILD
new file mode 100644
index 00000000000..7a79290ce74
--- /dev/null
+++ b/testing/rcon/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=rcon
+pkgver=0.4
+pkgrel=0
+pkgdesc="Source RCON client for command line."
+url="https://github.com/n0la/rcon"
+arch="all"
+license="BSD 2-Clause"
+makedepends="bash-completion cmake glib-dev"
+checkdepends="check-dev"
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/n0la/rcon/archive/$pkgver.tar.gz"
+
+build() {
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
+}
+
+sha512sums="99554288ed6a7061e68d28b60c77664ef21591aa9948a09c25a0b256b13eb06197b97ee44feb9f79bdef68ca61516b0235126948cbd13dff550f843509b93d9e rcon-0.4.tar.gz"