aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libqxp/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libqxp/APKBUILD b/community/libqxp/APKBUILD
new file mode 100644
index 00000000000..ac8de356124
--- /dev/null
+++ b/community/libqxp/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=libqxp
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Library that parses the file format of QuarkXPress documents."
+url="https://wiki.documentfoundation.org/DLP/Libraries/libqxp"
+arch="all"
+license="MPL-2.0"
+makedepends="librevenge-dev icu-dev doxygen"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://dev-www.libreoffice.org/src/libqxp/libqxp-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a03a9ada658a92f4d985cad91d467b3916334c74dc26c1e4de89e3929e0135ca0e9c7e7e18ce616ef56a67863ec19c2638494400785849017f9a4776df07c607 libqxp-0.0.1.tar.xz"