aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libgweather/APKBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/community/libgweather/APKBUILD b/community/libgweather/APKBUILD
index ab91702eefa..a576cb97fef 100644
--- a/community/libgweather/APKBUILD
+++ b/community/libgweather/APKBUILD
@@ -1,43 +1,37 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgweather
-pkgver=3.24.1
+pkgver=3.26.0
pkgrel=0
pkgdesc="GNOME weather library"
url="http://www.gnome.org/"
arch="all"
license="LGPL"
depends="tzdata"
-makedepends="gtk+3.0-dev libsoup-dev libxml2-dev glib-dev geocode-glib-dev gobject-introspection-dev"
-install=""
+makedepends="gtk+3.0-dev libsoup-dev libxml2-dev
+ glib-dev geocode-glib-dev gobject-introspection-dev
+ libxml2-utils gtk-doc py-six"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
-
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc \
- || return 1
- make || return 1
+ --sysconfdir=/etc
+ make
}
+check() {
+ cd "$builddir"
+ make check
+}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-sha512sums="564464d7a18a8e0320871ea418b1163163941c950c5acea5ee65a087e44c4d81e019e2e3e4cb6751989f823cbb7c5691713d3dcef72aeaf6ff264e61b6f7b4b4 libgweather-3.24.1.tar.xz"
+sha512sums="46fcc8319861237f908218b223102217591d731803093727a159912cefbd82017e1e064535d785e7f4ee6d227b47aff3240a14396fb9dc06ab26343720473606 libgweather-3.26.0.tar.xz"