aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/gegl/APKBUILD36
-rw-r--r--testing/gegl/gegl-uclibc.patch22
2 files changed, 58 insertions, 0 deletions
diff --git a/testing/gegl/APKBUILD b/testing/gegl/APKBUILD
new file mode 100644
index 00000000000..1db5bd38f12
--- /dev/null
+++ b/testing/gegl/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gegl
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Graph based image processing framework"
+url="http://www.gegl.org/"
+license="GPL3 LGPL3"
+makedepends="babl-dev libpng-dev jpeg-dev gtk+-dev librsvg-dev lua-dev"
+subpackages="$pkgname-dev"
+source="ftp://ftp.gimp.org/pub/$pkgname/0.1/$pkgname-$pkgver.tar.bz2
+ gegl-uclibc.patch"
+
+depends_dev="babl-dev glib-dev"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-librsvg \
+ --disable-docs \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="d35ffe17dc042652eca3205488ece262 gegl-0.1.2.tar.bz2
+e8efbd53553220b97650a3b693461fa5 gegl-uclibc.patch"
diff --git a/testing/gegl/gegl-uclibc.patch b/testing/gegl/gegl-uclibc.patch
new file mode 100644
index 00000000000..cb93f0fec75
--- /dev/null
+++ b/testing/gegl/gegl-uclibc.patch
@@ -0,0 +1,22 @@
+--- ./gegl/buffer/gegl-buffer.c.orig
++++ ./gegl/buffer/gegl-buffer.c
+@@ -80,7 +80,7 @@
+ /* #define GEGL_BUFFER_DEBUG_ALLOCATIONS to print allocation stack
+ * traces for leaked GeglBuffers using GNU C libs backtrace_symbols()
+ */
+-#ifndef G_OS_WIN32
++#if !defined(G_OS_WIN32) && !defined(__UCLIBC__)
+ #include <execinfo.h>
+ #endif
+
+@@ -876,8 +876,8 @@
+ gegl_buffer_get_alloc_stack (void)
+ {
+ char *result = NULL;
+-#ifdef G_OS_WIN32
+- result = g_strdup ("backtrack not available on win32\n");
++#if defined(G_OS_WIN32) || defined(__UCLIBC__)
++ result = g_strdup ("backtrack not available\n");
+ #else
+ void *functions[MAX_N_FUNCTIONS];
+ int n_functions = 0;