aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/bitchx/APKBUILD19
-rw-r--r--main/bitchx/bitchx-busybox-cpio.patch11
2 files changed, 8 insertions, 22 deletions
diff --git a/main/bitchx/APKBUILD b/main/bitchx/APKBUILD
index 0096b33c11b..dde0e6fe5b4 100644
--- a/main/bitchx/APKBUILD
+++ b/main/bitchx/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=bitchx
-pkgver=1.2
-pkgrel=2
+pkgver=1.2.1
+pkgrel=0
pkgdesc="An IRC client"
url="http://bitchx.com/"
arch="all"
@@ -12,10 +12,10 @@ depends_dev="tcl-dev openssl-dev ncurses-dev"
makedepends="$depends_dev coreutils"
install=""
subpackages="$pkgname-doc"
-source="http://dev.alpinelinux.org/archive/bitchx/BitchX-$pkgver-final.tar.gz
- bitchx-busybox-cpio.patch"
+source="http://downloads.sourceforge.net/project/bitchx/ircii-pana/bitchx-$pkgver/bitchx-$pkgver.tar.gz
+ "
-_builddir="$srcdir"/BitchX-$pkgver
+_builddir="$srcdir"/bitchx-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -49,9 +49,6 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="5c4947f5a345574e28d93f78cb191ce4 BitchX-1.2-final.tar.gz
-76561954440fc1c5545f4a0f20a8c60c bitchx-busybox-cpio.patch"
-sha256sums="7058d4be640c881fe91cbda6701b271c47846e0d3d7a13b52a3a36948094ec36 BitchX-1.2-final.tar.gz
-fde4078c35e36d4292655361f06d2682c471d2249b09f9535b8a57dc6ed7f71c bitchx-busybox-cpio.patch"
-sha512sums="b9597da0e029bb79be5fa164850bafe5efadb813be8d4cabbf0921e4544db39f1b7d41faa1042d9576268f964f3e70c2b76befd28a9c8cbad67415fa228fba2f BitchX-1.2-final.tar.gz
-542d3b23d396d8a98f1a69fd639f8adc0d10a35ee1f91810cc4dd986dd01545ba8df4a8fa2f1a3a04b0dab2b296efdeb2f4cf8dab24d8209e0a44f8c83492b99 bitchx-busybox-cpio.patch"
+md5sums="4da13a2dcfa17847168e50e62be4f67a bitchx-1.2.1.tar.gz"
+sha256sums="2d270500dd42b5e2b191980d584f6587ca8a0dbda26b35ce7fadb519f53c83e2 bitchx-1.2.1.tar.gz"
+sha512sums="d5e0a151c69a85cca2544db8478af9fbd8fca17f882993fab7f898a95221087bf6219ad2144caedecb5bc508dfa02fa724737c615fbda47aeb8df8298cdfd645 bitchx-1.2.1.tar.gz"
diff --git a/main/bitchx/bitchx-busybox-cpio.patch b/main/bitchx/bitchx-busybox-cpio.patch
deleted file mode 100644
index f854749b5f4..00000000000
--- a/main/bitchx/bitchx-busybox-cpio.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- BitchX-1.2/Makefile.in
-+++ BitchX-1.2.mod/Makefile.in
-@@ -212,7 +212,7 @@
-
- installhelp: installdirs
- cd $(top_srcdir)/bitchx-docs && \
-- find . -name .svn -prune -o -print | cpio -pdmu -R `id -un`:`id -gn` "$(DESTDIR)$(HELPDIR)"
-+ find . -name .svn -prune -o -print | cpio -pdmu "$(DESTDIR)$(HELPDIR)"
- (find "$(DESTDIR)$(HELPDIR)" -type f ! -name '*.bz2' ! -name '*.gz' | \
- (xargs bzip2 -9f || xargs gzip -9f) || :) 2>/dev/null
-