aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/wireshark/APKBUILD51
1 files changed, 32 insertions, 19 deletions
diff --git a/community/wireshark/APKBUILD b/community/wireshark/APKBUILD
index 645f7624a7f..0691e080da5 100644
--- a/community/wireshark/APKBUILD
+++ b/community/wireshark/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
-pkgver=2.2.6
+pkgver=2.2.7
pkgrel=0
pkgdesc="A network protocol analyzer - GTK version"
url="http://www.wireshark.org"
@@ -21,26 +21,39 @@ source="http://www.wireshark.org/download/src/$pkgname-$pkgver.tar.bz2
builddir="$srcdir"/$pkgname-$pkgver
# security fixes:
+# 2.2.7-r0:
+# - CVE-2017-9343
+# - CVE-2017-9344
+# - CVE-2017-9345
+# - CVE-2017-9346
+# - CVE-2017-9347
+# - CVE-2017-9348
+# - CVE-2017-9349
+# - CVE-2017-9350
+# - CVE-2017-9351
+# - CVE-2017-9352
+# - CVE-2017-9353
+# - CVE-2017-9354
# 2.2.5-r0:
-# - CVE-2017-6467
-# - CVE-2017-6468
-# - CVE-2017-6469
-# - CVE-2017-6470
-# - CVE-2017-6471
-# - CVE-2017-6472
-# - CVE-2017-6473
-# - CVE-2017-6474
+# - CVE-2017-6467
+# - CVE-2017-6468
+# - CVE-2017-6469
+# - CVE-2017-6470
+# - CVE-2017-6471
+# - CVE-2017-6472
+# - CVE-2017-6473
+# - CVE-2017-6474
# 2.2.4-r1:
-# - CVE-2017-6014
+# - CVE-2017-6014
# 2.0.5-r0:
-# - CVE-2016-6505
-# - CVE-2016-6506
-# - CVE-2016-6508
-# - CVE-2016-6509
-# - CVE-2016-6510
-# - CVE-2016-6511
-# - CVE-2016-6512
-# - CVE-2016-6513
+# - CVE-2016-6505
+# - CVE-2016-6506
+# - CVE-2016-6508
+# - CVE-2016-6509
+# - CVE-2016-6510
+# - CVE-2016-6511
+# - CVE-2016-6512
+# - CVE-2016-6513
build() {
cd "$builddir"
@@ -92,5 +105,5 @@ gtk() {
mv "$pkgdir"/usr/bin/wireshark-gtk "$subpkgdir"/usr/bin/
}
-sha512sums="d373254801b2d9ae248ff45be09ac36e1916b832430b8f57271421cbd2113c1ffa914ef23c7a1e704d8d5f666f0d4de5bcd9ef9d3801686a35511a5f2a230f3f wireshark-2.2.6.tar.bz2
+sha512sums="417836810eb895b3f2a6ac1cfd138fb0275382ea2edc60fc5f5e5f8ce433b56b8120aa8b58b4f77296986630fdf49e4c5c3859b2c2c5e26b1ce0651393b7d716 wireshark-2.2.7.tar.bz2
d462e3289c1350a9f712a21d2d1973977e5dd7989f7beff4b71498551174458f572a23f267c83552f088466cb9d2721df2b2eb807514db6ad1e0877dbc87fc6d fix-androiddump.patch"