aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/alpine-make-vm-image/APKBUILD10
-rw-r--r--community/alpine-make-vm-image/no-hardened.patch22
2 files changed, 4 insertions, 28 deletions
diff --git a/community/alpine-make-vm-image/APKBUILD b/community/alpine-make-vm-image/APKBUILD
index 5198da9197c..527d8cef745 100644
--- a/community/alpine-make-vm-image/APKBUILD
+++ b/community/alpine-make-vm-image/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=alpine-make-vm-image
-pkgver=0.2.2
+pkgver=0.3.0
pkgrel=0
pkgdesc="Make customized Alpine Linux disk image for virtual machines"
url="https://github.com/alpinelinux/alpine-make-vm-image"
@@ -9,8 +9,7 @@ arch="noarch"
license="MIT"
depends="qemu-img"
source="$pkgname-$pkgver.tar.gz::https://github.com/alpinelinux/$pkgname/archive/v$pkgver.tar.gz
- only-qemu-img-is-needed.patch
- no-hardened.patch"
+ only-qemu-img-is-needed.patch"
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # no suitable tests provided
@@ -19,6 +18,5 @@ package() {
make install DESTDIR="$pkgdir" PREFIX=/usr
}
-sha512sums="1169334c4b398da95ff9c115072c09fe43dda06b4cb60a032b87b74023f73c635f52cfddf7f824faff6bef016fc7a81201f66bf22d12cb02438d9d4bc059297c alpine-make-vm-image-0.2.2.tar.gz
-54f1e16ae074dee34443e4b8f82e3eb3c07b97de515508a6b9318ed0c4db572f18d2a073b1d12bd1843a9aff00351a337b93eaed78a1046880f5da064e2230b2 only-qemu-img-is-needed.patch
-6de07784bf7e64799fc1cb8487efc784ac1e8f6a036f8c94d8e126fa9554d6848477f21590f88c251d0ee5b1ca5d94f350cd3e47092708828b3f94ea8a0c3a5f no-hardened.patch"
+sha512sums="d47c145231d5607fab3fc14027b988074df0edbb96ff7d2a2d9ffc70057c68b8fa43506d483321b1ef6b7dbc907afa455761d05dcb1333bebc17eef9bd5eadd9 alpine-make-vm-image-0.3.0.tar.gz
+54f1e16ae074dee34443e4b8f82e3eb3c07b97de515508a6b9318ed0c4db572f18d2a073b1d12bd1843a9aff00351a337b93eaed78a1046880f5da064e2230b2 only-qemu-img-is-needed.patch"
diff --git a/community/alpine-make-vm-image/no-hardened.patch b/community/alpine-make-vm-image/no-hardened.patch
deleted file mode 100644
index cd95cb0156c..00000000000
--- a/community/alpine-make-vm-image/no-hardened.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/alpine-make-vm-image
-+++ b/alpine-make-vm-image
-@@ -32,8 +32,8 @@
- # $ROOTFS is always included, don't specify them here.
- # Default is "scsi virtio".
- #
--# -k --kernel-flavor KERNEL_FLAVOR The kernel flavour to install; vanilla, hardened,
--# or virthardened. Default is virthardened.
-+# -k --kernel-flavor KERNEL_FLAVOR The kernel flavour to install; vanilla or virt.
-+# Default is virt.
- #
- # --keys-dir KEYS_DIR Path of directory with Alpine keys to copy into the image.
- # Default is /etc/apk/keys.
-@@ -295,7 +295,7 @@
- : ${IMAGE_FORMAT:=}
- : ${IMAGE_SIZE:="2G"}
- : ${INITFS_FEATURES:="scsi virtio"}
--: ${KERNEL_FLAVOR:="virthardened"}
-+: ${KERNEL_FLAVOR:="virt"}
- : ${KEYS_DIR:="/etc/apk/keys"}
- : ${PACKAGES:=}
- : ${REPOS_FILE:="/etc/apk/repositories"}