aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/qt5-qtbase/APKBUILD10
-rw-r--r--community/qt5-qtbase/hack-openssl_test.patch11
-rw-r--r--community/qt5-qtbase/libressl-compat.patch23
3 files changed, 4 insertions, 40 deletions
diff --git a/community/qt5-qtbase/APKBUILD b/community/qt5-qtbase/APKBUILD
index 312165cf278..41dc69db692 100644
--- a/community/qt5-qtbase/APKBUILD
+++ b/community/qt5-qtbase/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt5-qtbase
_pkgname=${pkgname/qt5-//}-everywhere-src
-pkgver=5.10.1
+pkgver=5.12.0
_ver=${pkgver/_p/-}
_ver=${_ver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
-pkgrel=3
+pkgrel=0
pkgdesc="Qt5 - QtBase components"
url="http://qt-project.org/"
arch="all"
@@ -56,7 +56,6 @@ case $pkgver in
esac
source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/$_pkgname-$_V.tar.xz
qt-musl-iconv-no-bom.patch
- libressl-compat.patch
"
_qt5_prefix=/usr/lib/qt5
@@ -203,6 +202,5 @@ x11() {
return 0
}
-sha512sums="abc8087bb7c5db2a668ba87cef67ab7ab9d884b770bce916b7fe7bf4e0a1fac47114eff50e15bd9efed66d63307d6aceed5cb097aa2ae5df98cffd11af8691ba qtbase-everywhere-src-5.10.1.tar.xz
-7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch
-c23ceb261aeefdd1ba2b51a6487893b1a5d88e031646b06741e2f52f045bd0e387d1f9c033391bb187fedbb74add3e495909f9ebcc9da61617b21be33c597d57 libressl-compat.patch"
+sha512sums="8e6c51b754840d17e694b5b4a0d732afe04ebe48d166bca429db01ce3ac9014bb0ed35fe99ad165973889d96919f6b6774429585bae9a7fdba6b07f4c1eb3570 qtbase-everywhere-src-5.12.0.tar.xz
+7d68421a14f0259535c977d8a521c98918193c107b76ac664571b12f5b0d7588a0d0e1297af412a26753a393b21f3f44c3274fa8ab5bc87f03705a3a03acb444 qt-musl-iconv-no-bom.patch"
diff --git a/community/qt5-qtbase/hack-openssl_test.patch b/community/qt5-qtbase/hack-openssl_test.patch
deleted file mode 100644
index fdf31b45df9..00000000000
--- a/community/qt5-qtbase/hack-openssl_test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- qtbase/config.tests/unix/openssl/openssl.cpp 2016-09-16 07:49:42.000000000 +0200
-+++ qtbase/config.tests/unix/openssl/openssl.cpp 2016-10-21 19:05:10.099362793 +0200
-@@ -39,7 +39,7 @@
-
- #include <openssl/ssl.h>
-
--#if OPENSSL_VERSION_NUMBER-0 >= 0x10002000L && !defined(OPENSSL_NO_EC) && !defined(SSL_CTRL_SET_CURVES)
-+#if (OPENSSL_VERSION_NUMBER-0 >= 0x10002000L) && !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_EC) && !defined(SSL_CTRL_SET_CURVES)
- # error "OpenSSL was reported as >= 1.0.2 but is missing required features, possibly it's libressl which is unsupported"
- #endif
-
diff --git a/community/qt5-qtbase/libressl-compat.patch b/community/qt5-qtbase/libressl-compat.patch
deleted file mode 100644
index 65ca82bb9e0..00000000000
--- a/community/qt5-qtbase/libressl-compat.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./config.tests/unix/openssl11/openssl.cpp.orig 2018-04-24 09:59:45.918038335 +0200
-+++ ./config.tests/unix/openssl11/openssl.cpp 2018-04-24 10:01:21.255182441 +0200
-@@ -42,6 +42,9 @@
- #if !defined(OPENSSL_VERSION_NUMBER) || OPENSSL_VERSION_NUMBER-0 < 0x10100000L
- # error "OpenSSL >= 1.1 is required"
- #endif
-+#ifdef LIBRESSL_VERSION_NUMBER
-+# error "LibreSSL does not support all used OpenSSL-1.1 APIs yet."
-+#endif
-
- int main()
- {
---- ./src/network/ssl/qsslsocket_openssl_symbols_p.h.orig 2018-04-24 10:40:49.121761681 +0200
-+++ ./src/network/ssl/qsslsocket_openssl_symbols_p.h 2018-04-24 10:41:43.082843248 +0200
-@@ -232,7 +232,7 @@ BIO *q_BIO_new_mem_buf(void *a, int b);
- int q_BIO_read(BIO *a, void *b, int c);
- Q_AUTOTEST_EXPORT int q_BIO_write(BIO *a, const void *b, int c);
- int q_BN_num_bits(const BIGNUM *a);
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- int q_BN_is_word(BIGNUM *a, BN_ULONG w);
- #else
- // BN_is_word is implemented purely as a