aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore4
-rw-r--r--main/openssl/APKBUILD2
-rwxr-xr-xrebuild-alpine.sh13
3 files changed, 15 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index eae900da00f..9d9743a2346 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,7 @@
src
pkg
pkg-*
+main/vim/7.2.*
+main_*.txt
+testing_*.txt
+unstable_*.txt
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 1bab1385ffb..4a0f45f1a1f 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -45,7 +45,7 @@ dev() {
replaces="libcrypto openssl"
default_dev
# move symlinks
- mv "$pkgdir"/usr/lib/*.so "$subpkgdir"/usr/lib/
+ #mv "$pkgdir"/usr/lib/*.so "$subpkgdir"/usr/lib/
}
libcrypto() {
diff --git a/rebuild-alpine.sh b/rebuild-alpine.sh
index f613265ae42..a163e8a70b6 100755
--- a/rebuild-alpine.sh
+++ b/rebuild-alpine.sh
@@ -14,9 +14,15 @@ distclean () {
build () {
local pkgs
local maintainer
+ local pkgno
+ local failed
pkgs=$(./aport.lua deplist $rootdir $1)
+ pktcnt=$(echo $pkgs | wc -w)
+ pkgno=0
+ failed=0
for p in $pkgs ; do
- echo "Building $p"
+ pkgno=$(expr "$pkgno" + 1)
+ echo "Building $p ($pkgno of $pktcnt in $1 - $failed failed)"
cd $rootdir/$1/$p
abuild -rm > $rootdir/$1_$p.txt 2>&1
if [ "$?" = "0" ] ; then
@@ -27,7 +33,8 @@ build () {
maintainer="default maintainer"
fi
echo "Package $1/$p failed to build (output in $rootdir/$1_$p.txt)"
- echo "Package $1/$p failed to build. Notify $maintainer. Output is attached" | email -s "NOT SPAM $p build report" -a $rootdir/$1_$p.txt -n AlpineBuildBot -f build@alpinelinux.org amanison@anselsystems.com
+# echo "Package $1/$p failed to build. Notify $maintainer. Output is attached" | email -s "NOT SPAM $p build report" -a $rootdir/$1_$p.txt -n AlpineBuildBot -f build@alpinelinux.org amanison@anselsystems.com
+ failed=$(expr "$failed" + 1)
fi
done
cd $rootdir
@@ -43,7 +50,7 @@ fi
echo "Refresh aports tree"
git pull
-for s in main testing nonfree unstable ; do
+for s in main testing unstable ; do
echo "Building packages in $s"
build $s
done