aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/audacity/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/main/audacity/APKBUILD b/main/audacity/APKBUILD
index 6e43b827eaa..6137501f621 100644
--- a/main/audacity/APKBUILD
+++ b/main/audacity/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=audacity
pkgver=2.0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Multitrack audio editor"
url="http://audacity.sourceforge.net"
arch="all"
@@ -29,7 +29,15 @@ prepare() {
}
build() {
+ local _arch
+
cd "$_builddir"
+
+ case "$CTARGET" in
+ x86|x86_64) _arch="--enable-sse";;
+ *) _arch="--disable-sse";;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -39,6 +47,7 @@ build() {
--with-libsndfile=system \
--with-libsamplerate=system \
--without-libresample \
+ $_arch \
|| return 1
make || return 1
}