aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/docker/APKBUILD14
-rw-r--r--community/docker/openrc-fixes.patch27
2 files changed, 22 insertions, 19 deletions
diff --git a/community/docker/APKBUILD b/community/docker/APKBUILD
index 7bae55b1ff7..863ba489b36 100644
--- a/community/docker/APKBUILD
+++ b/community/docker/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=docker
-pkgver=1.8.3
+pkgver=1.9.0
pkgrel=0
_gitcommit=f4bf5c7
pkgdesc="Pack, ship and run any application as a lightweight container"
@@ -93,9 +93,9 @@ vim() {
done
}
-md5sums="0c3fe93523b5e01ce0560505d0717e35 docker-1.8.3.tar.gz
-2c31dfb597ded751e566602611ddb6ae openrc-fixes.patch"
-sha256sums="a29026cf12db9d65c830d40c4e5a9d789d79cf51ff49fdad8da684c0ff4411f3 docker-1.8.3.tar.gz
-ae9c3c780ef5e9ffb5666cbe343b0ecb9f498f1ab5d68373b39eea76b68a0f7c openrc-fixes.patch"
-sha512sums="b6e6139dfb063aaed565e73689a7133a7a8f09d4e0580ab383d8e1fe71282d5215f737d53473bc20241e89df1460f318d6a2c9dd7e0350218d666602d4ba515c docker-1.8.3.tar.gz
-79e78eed7eb1bfc468103fd4b171f66eabbffd3e504bfe1b8bdb40441292f316f6584fae415b93f0630d6975f888f1db4fb702886e78b6adc3a9a156a80de9b3 openrc-fixes.patch"
+md5sums="b104e844d3f8b9c91cf587d33bb0a81e docker-1.9.0.tar.gz
+506e32a6157a7f92e67511111fba6fe8 openrc-fixes.patch"
+sha256sums="1c06baea61971a711f9e510800fb4de5e0d8a6560963cfdc891e0037b40dc974 docker-1.9.0.tar.gz
+864d229e21dfa6c931b29b908093302a48837ddb1aa4205088f6f7fd4d7da4e3 openrc-fixes.patch"
+sha512sums="16c7fd900ff1122ccd62ce93b84209b026a165ff647cd4875e32c16251098c05e9e7de834cc6f27d164b5be168f8fd16323ec60593287a787f6fa8fcef144291 docker-1.9.0.tar.gz
+1162f62e8a7a5ded0c54cfe46014449efd67491bdb678fa22862117adb08206c909a3f98b0062125d25256dc1f48596b696bd4b19a8804d2862e758678a8bb62 openrc-fixes.patch"
diff --git a/community/docker/openrc-fixes.patch b/community/docker/openrc-fixes.patch
index 701459910bc..f350daaf93f 100644
--- a/community/docker/openrc-fixes.patch
+++ b/community/docker/openrc-fixes.patch
@@ -1,12 +1,14 @@
---- a/contrib/init/openrc/docker.initd 2015-02-10 17:14:37.000000000 -0100
-+++ b/contrib/init/openrc/docker.initd 2015-03-31 10:17:15.500070311 -0200
-@@ -8,11 +8,18 @@
- DOCKER_BINARY=${DOCKER_BINARY:-/usr/bin/docker}
- DOCKER_OPTS=${DOCKER_OPTS:-}
-
+diff --git a/contrib/init/openrc/docker.initd b/contrib/init/openrc/docker.initd
+index 26fa8ef..ea8a3b2 100644
+--- a/contrib/init/openrc/docker.initd
++++ b/contrib/init/openrc/docker.initd
+@@ -9,11 +9,18 @@ DOCKER_LOGFILE="${DOCKER_LOGFILE:-/var/log/${RC_SVCNAME}.log}"
+ start_stop_daemon_args="--background \
+ --stderr \"${DOCKER_LOGFILE}\" --stdout \"${DOCKER_LOGFILE}\""
+
+grsecdir=/proc/sys/kernel/grsecurity
+
- start() {
+ start_pre() {
checkpath -f -m 0644 -o root:docker "$DOCKER_LOGFILE"
+ for i in $disable_grsec; do
+ if [ -e "$grsecdir/$i" ]; then
@@ -14,16 +16,17 @@
+ echo 0 > "$grsecdir/$i"
+ fi
+ done
-
+
ulimit -n 1048576
- ulimit -u 1048576
-
- ebegin "Starting docker daemon"
- start-stop-daemon --start --background \
+
+ return 0
+ }
+
--- a/contrib/init/openrc/docker.confd 2015-02-10 17:14:37.000000000 -0100
+++ b/contrib/init/openrc/docker.confd 2015-03-31 14:52:47.323685914 -0200
@@ -11,3 +11,6 @@
-
+
# any other random options you want to pass to docker
DOCKER_OPTS=""
+