aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/inkscape/APKBUILD27
-rw-r--r--community/inkscape/fix-crash.patch6
2 files changed, 18 insertions, 15 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index b2ca0a8725e..2f70abdfede 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
-pkgver=0.91
-pkgrel=16
+pkgver=0.92.1
+pkgrel=0
pkgdesc="A vector-based drawing program - svg compliant"
url="http://inkscape.sourceforge.net/"
arch="all"
license="GPL LGPL"
makedepends="
- autoconf automake
+ autoconf
+ automake
boost-dev
dbus-dev
gc-dev
@@ -16,6 +17,7 @@ makedepends="
gtkspell-dev
imagemagick-dev
lcms-dev
+ libtool
libxml2-dev
libxslt-dev
poppler-dev
@@ -25,18 +27,18 @@ makedepends="
depends="desktop-file-utils"
checkdepends="bash"
subpackages="$pkgname-doc $pkgname-lang $pkgname-view"
-source="https://launchpad.net/inkscape/$pkgver.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
+source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
fix-crash.patch
"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$builddir"
default_prepare
+ ./autogen.sh
#aclocal -I m4 && autoconf && automake -a && autoheader
# we enable fortify source by default so to silence warnings we
# remove it from cmdline
- sed -i -e '/CPPFLAGS=/s/-D_FORTIFY_SOURCE=2//' configure || return 1
+ sed -i -e '/CPPFLAGS=/s/-D_FORTIFY_SOURCE=2//' configure
}
build() {
@@ -49,9 +51,8 @@ build() {
--enable-lcms \
--enable-poppler-cairo \
--enable-dbusapi \
- --disable-strict-build \
- || return 1
- make || return 1
+ --disable-strict-build
+ make
}
check() {
@@ -61,7 +62,7 @@ check() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
view() {
@@ -77,5 +78,7 @@ doc() {
"$pkgdir"/usr/share/inkscape/tutorials \
"$subpkgdir"/usr/share/inkscape
}
-sha512sums="3778ef7d4a1c759a7afc093e55eefb69a78dcb60332655cc8ab8c481f54a3e6550df6070178390eb08588245531906b8bef33301f0765a4d28d6c7506fcf3bc7 inkscape-0.91.tar.bz2
-d91a72c4363a5cd736593478580ef6175f6a7db0b601bf3a4af5c97c4bd1c295feb9e31365d5185be4d9cf4fddd642821a43337d914d6c257bef6c450d7ef70a fix-crash.patch"
+
+sha512sums="f8f3bfb812a214216c3ffac7064a4619f847cf9810417c782481dba12e6c6a44123c8b8a9289fbf5287f2e6b6df39a641d94a000d842faee5ff808eec86187a0 inkscape-0.92.1.tar.bz2
+5611130bde0734b2dbc3d7c56c84d2ffe929f8eaaa739501a25dab6a695ef051e9acf74280479fa8e1c058a429f3f48b9800c0935ec07e81b1b86174f548cb84 fix-crash.patch"
+
diff --git a/community/inkscape/fix-crash.patch b/community/inkscape/fix-crash.patch
index e28aac49d2c..7cb59912979 100644
--- a/community/inkscape/fix-crash.patch
+++ b/community/inkscape/fix-crash.patch
@@ -3,9 +3,9 @@ From: Timo Teräs <timo.teras@iki.fi>
Remove redundant object instantiation which yields returning c_str to
temporary stack object.
---- inkscape-0.91/src/libnrtype/FontFactory.cpp 2015-12-23 19:36:15.310394043 +0200
-+++ inkscape-0.91/src/libnrtype/FontFactory.cpp 2015-12-23 19:35:31.876527221 +0200
-@@ -194,7 +194,7 @@
+--- inkscape-0.92.1/src/libnrtype/FontFactory.cpp 2015-12-23 19:36:15.310394043 +0200
++++ inkscape-0.92.1/src/libnrtype/FontFactory.cpp 2015-12-23 19:35:31.876527221 +0200
+@@ -196,7 +196,7 @@
const char *pangoFamily = pango_font_description_get_family(fontDescr);
if (pangoFamily && ((it = fontNameMap.find(pangoFamily)) != fontNameMap.end())) {