summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/vlc/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index 7e7bbb7ea30..373e7038596 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
pkgver=1.1.7
-pkgrel=4
+pkgrel=6
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
url="http://www.videolan.org/vlc/"
arch="all"
@@ -129,15 +129,12 @@ build ()
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir"/ install || return 1
+ make DESTDIR="$pkgdir" install || return 1
# for res in 16 32 48 128; do
# install -D -m644 share/vlc${res}x${res}.png \
# "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png || return 1
# done
rm -rf "$pkgdir"/usr/lib/mozilla
-# FIXME: for some reason libavcodec_plugin does not get installed
- install -m644 $_builddir/modules/codec/avcodec/.libs/libavcodec_plugin.so \
- $pkgdir/usr/lib/vlc/plugins/codec/libavcodec_plugin.so
}
_mv() {
@@ -154,7 +151,7 @@ xorg() {
cd "$pkgdir"
for i in $(find -type f ); do
if ldd $i 2>/dev/null | grep -q libX; then
- _mv "$i" || return 1
+ echo $i | grep libavcodec_plugin.so || _mv "$i" || return 1
fi
done