summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--extra/fetchmail/APKBUILD6
-rw-r--r--extra/fetchmail/fetchmail.post-install2
2 files changed, 4 insertions, 4 deletions
diff --git a/extra/fetchmail/APKBUILD b/extra/fetchmail/APKBUILD
index bb8d1072d4e..bef000144cb 100644
--- a/extra/fetchmail/APKBUILD
+++ b/extra/fetchmail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetchmail
pkgver=6.3.9
-pkgrel=1
+pkgrel=2
pkgdesc="A remote-mail retrieval and forwarding utility"
url="http://fetchmail.berlios.de/"
license="GPL"
@@ -25,7 +25,7 @@ build() {
make || return 1
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/fetchmail.initd "$pkgdir"/etc/init.d/fetchmail
- install -d "$pkgdir"/var/lib/fetchmail
+ install -d "$pkgdir"/var/lib/fetchmail "$pkgdir"/var/run/fetchmail
}
fetchmailconf() {
@@ -40,5 +40,5 @@ fetchmailconf() {
md5sums="72c20ad2b9629f1a109668b05a84d823 fetchmail-6.3.9.tar.bz2
5a2fc8e8b3115fe2b9bf23503fb8f0a4 fetchmail.pre-install
-e27237ed73ad183ddd06dfd5e3dd0da7 fetchmail.post-install
+4b451d102e92926b6b6c1774f4260310 fetchmail.post-install
9a64c2b77d1a03a1eb8648a32d46b2c5 fetchmail.initd"
diff --git a/extra/fetchmail/fetchmail.post-install b/extra/fetchmail/fetchmail.post-install
index 9ca24ddcd86..b16bfcc3e42 100644
--- a/extra/fetchmail/fetchmail.post-install
+++ b/extra/fetchmail/fetchmail.post-install
@@ -1,3 +1,3 @@
#!/bin/sh
-chown fetchmail:fetchmail /var/lib/fetchmail
+chown fetchmail:fetchmail /var/*/fetchmail