summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xabuild.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/abuild.in b/abuild.in
index e1e9516bc44..0f679c940fc 100755
--- a/abuild.in
+++ b/abuild.in
@@ -110,6 +110,13 @@ sanitycheck() {
[ -z "$url" ] && die "Missing url in APKBUILD"
[ -z "$license" ] && die "Missing license in APKBULID"
+ # check so no package names starts with -
+ for i in $pkgname $subpackages; do
+ case $i in
+ -*) die "${i%:*} is not a valid package name";;
+ esac
+ done
+
# check if CARCH, CBUILD, CHOST and CTARGET is set
if [ -z "$CARCH" ]; then
case "$(uname -m)" in