summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/pinentry/APKBUILD44
-rw-r--r--main/pinentry/pinentry-gtk.post-deinstall8
-rw-r--r--main/pinentry/pinentry-gtk.post-install4
-rw-r--r--main/pinentry/pinentry.post-deinstall6
-rw-r--r--main/pinentry/pinentry.post-install6
5 files changed, 47 insertions, 21 deletions
diff --git a/main/pinentry/APKBUILD b/main/pinentry/APKBUILD
index d9fbe9a5ba2..3f08adac730 100644
--- a/main/pinentry/APKBUILD
+++ b/main/pinentry/APKBUILD
@@ -1,42 +1,44 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pinentry
-pkgver=0.7.6
+pkgver=0.8.0
_uiconv_ver=0.3
-pkgrel=1
+pkgrel=0
pkgdesc="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
url="http://www.gnupg.org/aegypten2"
license="GPL-2"
-depends="ncurses libcap"
-makedepends="ncurses-dev libcap-dev"
-subpackages="$pkgname-doc"
+depends=
+install="pinentry.post-install pinentry.post-deinstall"
+makedepends="ncurses-dev libcap-dev gtk+-dev"
+subpackages="$pkgname-doc $pkgname-gtk"
source="ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
http://git.alpinelinux.org/cgit/uiconv/snapshot/uiconv-$_uiconv_ver.tar.bz2
"
build () {
- # we build it against uiconv to avoid the bloaty GNU libiconv.
- # it will be linked statically so we don't need it in depends
- cd "$srcdir/uiconv-$_uiconv_ver"
- make
- make DESTDIR="$srcdir" PREFIX=/uiconv install
-
cd "$srcdir"/$pkgname-$pkgver
-
- # the configure script have a broken --with-libiconv-prefix option
- # so we set the -I and -L flags hard
- export CFLAGS="$CFLAGS -I $srcdir/uiconv/include"
- export LDFLAGS="$LDFLAGS -L $srcdir/uiconv/lib"
-
./configure --prefix=/usr \
--disable-pinentry-gtk \
- --disable-pinentry-gtk2 \
+ --enable-pinentry-gtk2 \
--disable-pinentry-qt \
--enable-pinentry-curses \
- --enable-fallback-curses \
- --with-libiconv-prefix="$srcdir"/uiconv
+ --enable-pinentry-gtk2 \
+ --enable-fallback-curses
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
+ # created by post install scripts so we can override with gtk version
+ rm -f "$pkgdir"/usr/bin/pinentry
+}
+
+gtk() {
+ install="pinentry-gtk.post-install pinentry-gtk.post-deinstall"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/pinentry-gtk* "$subpkgdir"/usr/bin/
}
-md5sums="5a4f676375fa882009da02013d77210f pinentry-0.7.6.tar.gz
+
+md5sums="590be1b00f9ab63205843c7fed8caf35 pinentry-0.8.0.tar.gz
5cd7f80085324d08cb976fec674cd98d uiconv-0.3.tar.bz2"
diff --git a/main/pinentry/pinentry-gtk.post-deinstall b/main/pinentry/pinentry-gtk.post-deinstall
new file mode 100644
index 00000000000..887ef798aea
--- /dev/null
+++ b/main/pinentry/pinentry-gtk.post-deinstall
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+if [ -f /usr/bin/pinentry-curses ]; then
+ ln -sf pinentry-curses /usr/bin/pinentry
+else
+ rm -f /usr/bin/pinentry
+fi
+
diff --git a/main/pinentry/pinentry-gtk.post-install b/main/pinentry/pinentry-gtk.post-install
new file mode 100644
index 00000000000..8b51ca005f4
--- /dev/null
+++ b/main/pinentry/pinentry-gtk.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+ln -sf pinentry-gtk-2 /usr/bin/pinentry
+
diff --git a/main/pinentry/pinentry.post-deinstall b/main/pinentry/pinentry.post-deinstall
new file mode 100644
index 00000000000..38939e5b49f
--- /dev/null
+++ b/main/pinentry/pinentry.post-deinstall
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if ! [ -f /usr/bin/pinentry-gtk-2 ]; then
+ rm -f /usr/bin/pinentry
+fi
+
diff --git a/main/pinentry/pinentry.post-install b/main/pinentry/pinentry.post-install
new file mode 100644
index 00000000000..0dfd31e955a
--- /dev/null
+++ b/main/pinentry/pinentry.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if ! [ -f /usr/bin/pinentry-gtk-2 ]; then
+ ln -sf pinentry-curses /usr/bin/pinentry
+fi
+