summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/claws-mail/APKBUILD10
-rw-r--r--main/claws-mail/gnutls313.patch12
-rw-r--r--main/claws-mail/libc-version.patch22
3 files changed, 3 insertions, 41 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
index 81a50dd6c31..ae0ebd1cbca 100644
--- a/main/claws-mail/APKBUILD
+++ b/main/claws-mail/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
-pkgver=3.8.1
-pkgrel=3
+pkgver=3.9.0
+pkgrel=0
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
arch="all"
@@ -18,8 +18,6 @@ makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
depends=
install=
source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
- libc-version.patch
- gnutls313.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -89,6 +87,4 @@ smime() {
"$subpkgdir"/usr/lib/claws-mail/plugins/
}
-md5sums="d388929fb1c8f04d4bcb2139faaf9e70 claws-mail-3.8.1.tar.bz2
-f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch
-21bdc9d324f9424e0071bb73be169977 gnutls313.patch"
+md5sums="4c5ac7b21f0ed17d0f6404124c2229a4 claws-mail-3.9.0.tar.bz2"
diff --git a/main/claws-mail/gnutls313.patch b/main/claws-mail/gnutls313.patch
deleted file mode 100644
index 27040f7bdbb..00000000000
--- a/main/claws-mail/gnutls313.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/common/ssl_certificate.c b/src/common/ssl_certificate.c
-index efc5c53..8303f3e 100644
---- a/src/common/ssl_certificate.c
-+++ b/src/common/ssl_certificate.c
-@@ -92,6 +92,7 @@
- size_t size;
- gnutls_datum tmp;
- gnutls_x509_crt dest;
-+ size = 0;
-
- if (gnutls_x509_crt_init(&dest) != 0) {
- g_warning("couldn't gnutls_x509_crt_init\n");
diff --git a/main/claws-mail/libc-version.patch b/main/claws-mail/libc-version.patch
deleted file mode 100644
index c55c007baf2..00000000000
--- a/main/claws-mail/libc-version.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/crash.c.orig 2009-09-05 22:12:33.000000000 +0000
-+++ b/src/crash.c 2009-09-05 22:14:34.000000000 +0000
-@@ -42,7 +42,7 @@
- # include <sys/utsname.h>
- #endif
-
--#if defined(__GNU_LIBRARY__)
-+#if defined(__GNU_LIBRARY__) && !defined(__UCLIBC__)
- # include <gnu/libc-version.h>
- #endif
-
-@@ -446,7 +446,9 @@
- */
- static const gchar *get_lib_version(void)
- {
--#if defined(__GNU_LIBRARY__)
-+#if defined(__UCLIBC__)
-+ return g_strdup_printf("uClibc");
-+#elif defined(__GNU_LIBRARY__)
- return g_strdup_printf("GNU libc %s", gnu_get_libc_version());
- #else
- return g_strdup(_("Unknown"));