summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--extra/newt/APKBUILD35
-rw-r--r--extra/newt/newt-0.52.7-notcl.patch35
2 files changed, 70 insertions, 0 deletions
diff --git a/extra/newt/APKBUILD b/extra/newt/APKBUILD
new file mode 100644
index 00000000000..dc81b8b6709
--- /dev/null
+++ b/extra/newt/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=newt
+pkgver=0.52.8
+pkgrel=0
+pkgdesc="Redhat's Newt windowing toolkit development files"
+url="http://www.redhat.com/"
+license="LGPL-2"
+depends="uclibc slang popt ncurses"
+makedepends="slang-dev popt-dev python-dev ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://distfiles.gentoo.org/distfiles/$pkgname-$pkgver.tar.gz
+ $pkgname-0.52.7-notcl.patch
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ sed -i -e 's:-lslang:-lslang -lncurses:g' \
+ -e 's:instroot:DESTDIR:g' Makefile.in || return 1
+
+ ./configure --prefix=/usr \
+ --without-gpm \
+ --without-tcl \
+ --disable-nls
+ make -j1 RPM_OPT_FLAGS="$CFLAGS" || return 1
+ # TODO: fix the make install target to not try install po files
+ make -j1 DESTDIR="$pkgdir" prefix="/usr" RPM_OPT_FLAGS="ERROR" install \
+ || true
+}
+md5sums="0daef93590e9b6fd3419c871e75f9fa7 newt-0.52.8.tar.gz
+6780156f3b66a3f05efe1ee821617031 newt-0.52.7-notcl.patch"
diff --git a/extra/newt/newt-0.52.7-notcl.patch b/extra/newt/newt-0.52.7-notcl.patch
new file mode 100644
index 00000000000..b9f86e6b605
--- /dev/null
+++ b/extra/newt/newt-0.52.7-notcl.patch
@@ -0,0 +1,35 @@
+--- newt-0.52.7/Makefile.in.orig 2008-01-15 16:57:12.000000000 +0100
++++ newt-0.52.7/Makefile.in 2008-01-15 16:58:38.000000000 +0100
+@@ -15,7 +15,7 @@
+ PYTHONVERS = @PYTHONVERS@
+ WHIPTCLSO = @WHIPTCLSO@
+
+-PROGS = test whiptail $(WHIPTCLSO) testgrid testtree showchars showkey
++PROGS = test whiptail testgrid testtree showchars showkey
+ TESTOBJS = test.o testgrid.o testtree.o showchars.o showkey.o
+ NDIALOGOBJS = whiptail.o dialogboxes.o
+ WHIPTCLOBJS = shared/whiptcl.o shared/dialogboxes.o
+@@ -78,9 +78,6 @@
+ whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
+ $(CC) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
+
+-whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
+- $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lslang -lpopt -lm
+-
+ $(LIBNEWT): $(LIBOBJS)
+ ar rv $@ $^
+
+@@ -120,12 +117,11 @@
+ install -m 644 whiptail.1 $(instroot)/$(man1dir)
+ make -C po datadir=$(instroot)/$(datadir) install
+
+-install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
++install-sh: sharedlib _snackmodule.so
+ [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
+ install -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
+ ln -sf $(LIBNEWTSONAME) $(instroot)/$(libdir)/libnewt.so
+ ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/$(LIBNEWTSONAME)
+- [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so $(instroot)/$(libdir) || :
+ for ver in $(PYTHONVERS) ; do \
+ [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
+ install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\