aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/bluedevil/APKBUILD9
-rw-r--r--community/bluedevil/fix-422684.patch63
-rw-r--r--community/breeze-grub/APKBUILD4
-rw-r--r--community/breeze-gtk/APKBUILD4
-rw-r--r--community/breeze-plymouth/APKBUILD4
-rw-r--r--community/breeze/APKBUILD4
-rw-r--r--community/discover/APKBUILD4
-rw-r--r--community/drkonqi/APKBUILD4
-rw-r--r--community/kactivitymanagerd/APKBUILD4
-rw-r--r--community/kde-cli-tools/APKBUILD4
-rw-r--r--community/kde-gtk-config/APKBUILD22
-rw-r--r--community/kdecoration/APKBUILD4
-rw-r--r--community/kdeplasma-addons/APKBUILD4
-rw-r--r--community/kgamma5/APKBUILD4
-rw-r--r--community/khotkeys/APKBUILD4
-rw-r--r--community/kinfocenter/APKBUILD4
-rw-r--r--community/kmenuedit/APKBUILD4
-rw-r--r--community/kscreen/APKBUILD4
-rw-r--r--community/kscreenlocker/APKBUILD4
-rw-r--r--community/ksshaskpass/APKBUILD4
-rw-r--r--community/ksysguard/APKBUILD4
-rw-r--r--community/kwallet-pam/APKBUILD4
-rw-r--r--community/kwayland-integration/APKBUILD4
-rw-r--r--community/kwayland-server/APKBUILD4
-rw-r--r--community/kwin/APKBUILD6
-rw-r--r--community/kwrited/APKBUILD4
-rw-r--r--community/libkscreen/APKBUILD4
-rw-r--r--community/libksysguard/APKBUILD24
-rw-r--r--community/milou/APKBUILD4
-rw-r--r--community/oxygen/APKBUILD4
-rw-r--r--community/plasma-browser-integration/APKBUILD4
-rw-r--r--community/plasma-desktop/APKBUILD70
-rw-r--r--community/plasma-integration/APKBUILD4
-rw-r--r--community/plasma-nano/APKBUILD4
-rw-r--r--community/plasma-nm/APKBUILD9
-rw-r--r--community/plasma-nm/fix-423093.patch36
-rw-r--r--community/plasma-pa/APKBUILD4
-rw-r--r--community/plasma-phone-components/APKBUILD14
-rw-r--r--community/plasma-sdk/APKBUILD4
-rw-r--r--community/plasma-thunderbolt/APKBUILD4
-rw-r--r--community/plasma-vault/APKBUILD9
-rw-r--r--community/plasma-vault/fix-422684.patch63
-rw-r--r--community/plasma-workspace-wallpapers/APKBUILD4
-rw-r--r--community/plasma-workspace/APKBUILD72
-rw-r--r--community/plasma-workspace/fix-422684.patch50
-rw-r--r--community/plasma-workspace/fix-with-gpsd-3.21.patch27
-rw-r--r--community/plasma/APKBUILD5
-rw-r--r--community/plymouth-kcm/APKBUILD4
-rw-r--r--community/polkit-kde-agent-1/APKBUILD4
-rw-r--r--community/powerdevil/APKBUILD4
-rw-r--r--community/sddm-kcm/APKBUILD4
-rw-r--r--community/signond/APKBUILD5
-rw-r--r--community/systemsettings/APKBUILD6
-rw-r--r--community/user-manager/APKBUILD30
-rw-r--r--community/xdg-desktop-portal-kde/APKBUILD22
55 files changed, 252 insertions, 434 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index a9fae321c6..1e966ebe44 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=bluedevil
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -9,9 +9,7 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends="kded bluez"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev plasma-framework-dev ki18n-dev kio-dev bluez-qt-dev kded-dev kded shared-mime-info"
-source="https://download.kde.org/stable/plasma/$pkgver/bluedevil-$pkgver.tar.xz
- fix-422684.patch
- "
+source="https://download.kde.org/stable/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
@@ -31,5 +29,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="152702f37e46b3b359ff23705dcf347588691d87e1a0cbce940ef557f29e92fd9e129724ab37158b4daa00fdd38d31ad5197318dc09b33d7c834e562b6aff5dd bluedevil-5.19.5.tar.xz
-7b56d2868225def41002b402b315dd29917a192647dec6db64bc2519530823fbc08a129dad24370ba948c986c1fc67ac0f7fc1b441ddab0f6d952adadcfb8a6c fix-422684.patch"
+sha512sums="38a2703b9a5407166aba7227612cd861f473688a883dfaf9276c0809ec717f15c6cc2493bd7bcb2255f42a79edf1dd266ddcd20647897ee657452ae138af46dc bluedevil-5.20.0.tar.xz"
diff --git a/community/bluedevil/fix-422684.patch b/community/bluedevil/fix-422684.patch
deleted file mode 100644
index 9f0bae5984..0000000000
--- a/community/bluedevil/fix-422684.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Requested upstream to backport to fix KDE bug 422684
-https://bugs.kde.org/show_bug.cgi?id=422684
-
-This has been merged upstream and will not be necessary in the next full
-Plasma release
-
-From 161c1b92bced7996e92026ff9ae503593f6590f6 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Sun, 14 Jun 2020 09:10:38 -0600
-Subject: [PATCH] Port applet to use PlasmaExtras.PlaceholderMessage
-
-The Kirigami version uses QQC2 elements which don't respect the plasma
-theme and color scheme, leading to thing slooking out of place
-especially when using a dark color theme or scheme.
-
-Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
----
- CMakeLists.txt | 6 ------
- src/applet/package/contents/ui/FullRepresentation.qml | 4 +---
- 2 files changed, 1 insertion(+), 9 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d9067851..5ddce978 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -33,12 +33,6 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
- find_package(KDED ${KF5_MIN_VERSION} REQUIRED)
- find_package(SharedMimeInfo REQUIRED)
-
--find_package(KF5Kirigami2 ${KF5_MIN_VERSION} CONFIG)
--set_package_properties(KF5Kirigami2 PROPERTIES
-- DESCRIPTION "A QtQuick based components set"
-- TYPE RUNTIME
--)
--
- include(KDEInstallDirs)
- include(KDECMakeSettings)
- include(KDECompilerSettings NO_POLICY_SCOPE)
-diff --git a/src/applet/package/contents/ui/FullRepresentation.qml b/src/applet/package/contents/ui/FullRepresentation.qml
-index 5bd32f15..e77bf295 100644
---- a/src/applet/package/contents/ui/FullRepresentation.qml
-+++ b/src/applet/package/contents/ui/FullRepresentation.qml
-@@ -27,8 +27,6 @@ import org.kde.plasma.components 2.0 as PlasmaComponents
- import org.kde.plasma.components 3.0 as PlasmaComponents3
- import org.kde.plasma.private.bluetooth 1.0 as PlasmaBt
-
--import org.kde.kirigami 2.12 as Kirigami
--
- PlasmaComponents3.Page {
-
- Action {
-@@ -99,7 +97,7 @@ PlasmaComponents3.Page {
- // Not inside the ListView because we want the listview to be hidden
- // when Bluetooth is disabled, yet still show an "Enable Bluetooth"
- // message
-- Kirigami.PlaceholderMessage {
-+ PlasmaExtras.PlaceholderMessage {
- anchors.centerIn: parent
- anchors.left: parent.left
- anchors.right: parent.right
---
-GitLab
-
diff --git a/community/breeze-grub/APKBUILD b/community/breeze-grub/APKBUILD
index 6906644b23..1c861e9023 100644
--- a/community/breeze-grub/APKBUILD
+++ b/community/breeze-grub/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-grub
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Breeze theme for GRUB"
arch="noarch !s390x !armhf" # armhf blocked by extra-cmake-modules
@@ -20,4 +20,4 @@ package() {
install -d "$pkgdir"/usr/share/grub/themes
cp -r breeze "$pkgdir"/usr/share/grub/themes
}
-sha512sums="db589b3f8daf4518b517b74110b925319b610251e002c3e28fdd2e0a88d99c2d3108dbbe02257a60bb4b6a3e4b594febf26f7d2448ec1caeaf341d95cd02c0e3 breeze-grub-5.19.5.tar.xz"
+sha512sums="0954036373179357a6c32c47725a119964c94b808ef5b3325cea79ddc7f2decf2b5e7ce02421b258884b03b708a3e30adcdd212fae6e30cae23f49e1c783b558 breeze-grub-5.20.0.tar.xz"
diff --git a/community/breeze-gtk/APKBUILD b/community/breeze-gtk/APKBUILD
index 81cd00e8b5..5f9e4a7062 100644
--- a/community/breeze-gtk/APKBUILD
+++ b/community/breeze-gtk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-gtk
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="A GTK Theme Built to Match KDE's Breeze"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -27,4 +27,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="cb201730ba20745cdf04e8889830e1a5f6ac530435783ca1c01c52d456c650a88f459c871fb6e6b4ef36bc771dbaa4e2d03d7ad08906c910b7b9849678bf9f2f breeze-gtk-5.19.5.tar.xz"
+sha512sums="0eabe2961a6c78872bc0e4f6fb2e453d6686ba5b6abb0989e0b721fe9c87792172f25bf7afd3b3d8b3e31d1462348b0a6ad9a735d9d45577de089dc72cb80076 breeze-gtk-5.20.0.tar.xz"
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index b92b044b6c..ee83c87e74 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-plymouth
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://kde.org/"
@@ -25,4 +25,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="8f0739379c2ddb62b612acf65c41bee57e36d98a120289a1db3245467d118e18f3c0fe67905d990c586dfbe333c47f8671893726ad5ee9c28883d938e309963d breeze-plymouth-5.19.5.tar.xz"
+sha512sums="ba268f4971cf17311b78d0b1a977e6795221638258dbf9cfe99eb988d1c320d135d5efc7eab057ac6bfac620149db52b32edf074cba07c816a67b0a83e558183 breeze-plymouth-5.20.0.tar.xz"
diff --git a/community/breeze/APKBUILD b/community/breeze/APKBUILD
index b026e78193..52fe544e04 100644
--- a/community/breeze/APKBUILD
+++ b/community/breeze/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Artwork, styles and assets for the Breeze visual style for the Plasma Desktop"
arch="all !armhf" # disable on armhf due to missing qt5-qtdeclarative
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="6b67b147c34e3b143e0c4c400eb3133ab15b826f9046ad2e701114f3ceaa1e2d085d864f04c28f2bdc37464a2313c6d8b5983fab5ca9f22ccae90ef1528eb8c4 breeze-5.19.5.tar.xz"
+sha512sums="bb76c1b60ce7ff7b8fbabda232d1d50fe86fc0e2d56ad7feadb582b89ec796851f97f3339c7423cbb6e14db2fe609aeb4f5d046a2f26f8c6fed2336de2d0a16a breeze-5.20.0.tar.xz"
diff --git a/community/discover/APKBUILD b/community/discover/APKBUILD
index 87620e9bba..692aaab36c 100644
--- a/community/discover/APKBUILD
+++ b/community/discover/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=discover
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://userbase.kde.org/Discover"
@@ -79,4 +79,4 @@ backend_fwupd() {
"$subpkgdir"/usr/lib/qt5/plugins/discover/
}
-sha512sums="524fc45331631a305620f05fe67f780aee2dba7714978f32d9baa0d488185da801ee7a4d11592f2e07dfe395726b0c34d4ae7dfe3abf2b0e7632bdea27a714fd discover-5.19.5.tar.xz"
+sha512sums="70bda593c21f2b1cd039e254847c00b488beb3f9fc5560bce245656c277a38bd4be25b065730f832b6bedcbd2213f1c8b751cc1f3959c14b4c6480cc06d015a2 discover-5.20.0.tar.xz"
diff --git a/community/drkonqi/APKBUILD b/community/drkonqi/APKBUILD
index c423b06aca..f65ccff9c0 100644
--- a/community/drkonqi/APKBUILD
+++ b/community/drkonqi/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=drkonqi
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="0dcfcb5018f1024ad751c234f7e67b865f06c8e8bf5a1a95a160df2af97730ca111f4cc8614da646c8dbe042a206d3d4be214790abcf617ca454582161f0aa24 drkonqi-5.19.5.tar.xz"
+sha512sums="81b3bde1a786b5a8d341a1af21c4f92ab20c758d0a3f2d5dadfb2d07556bb4582e7fa852082220535ed2dade7d2b0f65f1d154a671bb6667a29cff07f7a1a267 drkonqi-5.20.0.tar.xz"
diff --git a/community/kactivitymanagerd/APKBUILD b/community/kactivitymanagerd/APKBUILD
index c15137da90..b8872e73cb 100644
--- a/community/kactivitymanagerd/APKBUILD
+++ b/community/kactivitymanagerd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kactivitymanagerd
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="System service to manage user's activities and track the usage patterns"
arch="all !armhf" # disable armhf due to missing qt5-qtdeclarative
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="884f839c68b94da264042262b730baf81ca4b65320daa2b4de2ecba0698728600f25de77feeb6ef69bc9d98b06e827d8ce467fb9d7b54807442d7d9cf2b9b9a7 kactivitymanagerd-5.19.5.tar.xz"
+sha512sums="f2f6664f511e397b3d246390175a7ae7d89a866076cff5833c97152212942165294cb7d224114a5a1b75ccb9c82402c4a3e16a0404e89390572497a34c711e4c kactivitymanagerd-5.20.0.tar.xz"
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index e6ba7028a1..43b5078a2b 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kde-cli-tools
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -32,4 +32,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9e8de408643caad7c0de52cd348c35678c92b478587a2e7fd6b0cfd1d93dd578d9060c58b1dacf4b0143840d61860b51f41b53b7c2349112b855c9bad3c9b897 kde-cli-tools-5.19.5.tar.xz"
+sha512sums="f3637edb92cf955e255d31bd857633716ac6072f2a2e0c95f070a2e91c83c624f1ea14e156c5b390dde48a4795bdafe412454b1c2dfeedd643cb8c91e2f23fd1 kde-cli-tools-5.20.0.tar.xz"
diff --git a/community/kde-gtk-config/APKBUILD b/community/kde-gtk-config/APKBUILD
index 57920ef101..fbf2257e5f 100644
--- a/community/kde-gtk-config/APKBUILD
+++ b/community/kde-gtk-config/APKBUILD
@@ -1,14 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kde-gtk-config
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="GTK2 and GTK3 Configurator for KDE"
arch="all !armhf" # qtdeclarative
url="https://cgit.kde.org/kde-gtk-config"
license="GPL-2.0 AND LGPL-2.1-only OR LGPL-3.0-only"
depends="gsettings-desktop-schemas"
-makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev ki18n-dev kio-dev kconfigwidgets-dev knewstuff-dev karchive-dev kcmutils-dev kiconthemes-dev gtk+2.0-dev gtk+3.0-dev gsettings-desktop-schemas-dev"
+makedepends="
+ extra-cmake-modules
+ gsettings-desktop-schemas-dev
+ gtk+2.0-dev
+ gtk+3.0-dev
+ karchive-dev
+ kcmutils-dev
+ kconfigwidgets-dev
+ kdecoration-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ knewstuff-dev
+ qt5-qtbase-dev
+ qt5-qtsvg-dev
+ sassc
+ "
source="https://download.kde.org/stable/plasma/$pkgver/kde-gtk-config-$pkgver.tar.xz"
build() {
@@ -27,4 +43,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d9875fc1af767b7f318520f386a62404779c33312eb5bad1eebc924a36ca05d822cf219b56548cd050e0965b0dfd581b5fee533a77fb5d745e51f63b350ff79c kde-gtk-config-5.19.5.tar.xz"
+sha512sums="04f1e3053b896e4c61d1e215b68c4eb97070d4062b1a394346d7236e1e80a6a8af080e970576af32498d5c74b63b21dafc9c12a92636ce6c03eac84442de0db1 kde-gtk-config-5.20.0.tar.xz"
diff --git a/community/kdecoration/APKBUILD b/community/kdecoration/APKBUILD
index 9edec60d3d..701a50009a 100644
--- a/community/kdecoration/APKBUILD
+++ b/community/kdecoration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdecoration
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Plugin based library to create window decorations"
arch="all !armhf"
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="74ce5ed6a071ebc484103a2efbfbf3f2f624852dc00e141ced85813571bffb351f832dd6162c1c672274006c7bf2c7b64d59e5224f5eca6d17cd3e3a2e35151b kdecoration-5.19.5.tar.xz"
+sha512sums="d0c50a45233ce11ca27a121f466e7cf6149368104025280874c11ee6adcc28a36be570979c0a7b89b66af174b302f132f44599a06783a5cb218c85610a87d946 kdecoration-5.20.0.tar.xz"
diff --git a/community/kdeplasma-addons/APKBUILD b/community/kdeplasma-addons/APKBUILD
index 1d0d0a88fb..b88da9faef 100644
--- a/community/kdeplasma-addons/APKBUILD
+++ b/community/kdeplasma-addons/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdeplasma-addons
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="All kind of addons to improve your Plasma experience"
# mips, ppc64le and s390x blocked by qt5-qtwebengine
@@ -37,4 +37,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="93de717c623605ceb9fdcedecdf656030b6e9bc360ce834ea918403f64f250029e9a2406bddc0b324e4738006d4ca155bc509f4a7d40c073a2aefb2017db9731 kdeplasma-addons-5.19.5.tar.xz"
+sha512sums="45484ddb8ef8eee0a793ff3d57dfd3fd143c4892eff7224cec847fc7c11becc0f10b54bc8533d331bc504df75e8c31522064165dee08d8b60093dbe4c626472f kdeplasma-addons-5.20.0.tar.xz"
diff --git a/community/kgamma5/APKBUILD b/community/kgamma5/APKBUILD
index 27bcf53747..82325b7903 100644
--- a/community/kgamma5/APKBUILD
+++ b/community/kgamma5/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kgamma5
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Adjust your monitor's gamma settings"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="bb758ac5a4ed21563bcdad3eca07a822a8bdebe5d5cf4862f92f2b38dc9a8fc4b15b8cf0e96d6a329b969eb36064c8723ec432a044cecf1c25fe43853cb8f567 kgamma5-5.19.5.tar.xz"
+sha512sums="8681f10c9706f9e2da0262ad64cec5615e3894574116d37877dfb8fe82bf859e3bcba7d0a446ae7e4eeb6c193c94e0725bce8a572f15ce458ea323c66fdf53c4 kgamma5-5.20.0.tar.xz"
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
index 096520c75c..c81d450852 100644
--- a/community/khotkeys/APKBUILD
+++ b/community/khotkeys/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=khotkeys
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -29,4 +29,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c7832ea7cb2890cbdf9d160b1658a393e105903e54b87cd10cf00f5bffa1b240e70685a201e2b4d580b4083e903770a2b26fd65f68f05302798320e7f20103be khotkeys-5.19.5.tar.xz"
+sha512sums="4d1315cec456af364023416e4ff526e143790a75cdb5fbdbd14a63fe13fee12f2cc7d0cccd7a2a4b4d21597b7511ead18a174614e71c41d658b1bb6fbc07393b khotkeys-5.20.0.tar.xz"
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index 506d1c570a..9ac34a8087 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kinfocenter
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="732d6111f59e099fb032966667b6d7907e607939884714a95f0a2e48903f8a0d7e2331a87611ee058a4bc18bcb012c92040415812243fab4d618a07f2e7dccaa kinfocenter-5.19.5.tar.xz"
+sha512sums="8e544db63341cf29e578271b29272d2407c014ddf181ba61f83c6200643e66433e06c067620bd18c9a0a5e337d794800c0e5ca762a2ff733c1de76551fdd5b11 kinfocenter-5.20.0.tar.xz"
diff --git a/community/kmenuedit/APKBUILD b/community/kmenuedit/APKBUILD
index 069cbb5f69..0c780d11d1 100644
--- a/community/kmenuedit/APKBUILD
+++ b/community/kmenuedit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kmenuedit
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE menu editor"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -28,4 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="332fa310a8a4d0c792e05db5427d16b3290998f0da5c7184d674d8104e8079bff51065575a98f61b83899df6cdd7f4be6daf0a5dc014f30bf1ced49c896e1241 kmenuedit-5.19.5.tar.xz"
+sha512sums="9948194bcc75b3b8ef21292ab47ead450476a468dc7777b0613a8bf65bd946ed38bd6264329d27e28879f1c02cee78e739e02463d0b6950696135d1f5dae0ab0 kmenuedit-5.20.0.tar.xz"
diff --git a/community/kscreen/APKBUILD b/community/kscreen/APKBUILD
index 4efe070f1c..8d597103c4 100644
--- a/community/kscreen/APKBUILD
+++ b/community/kscreen/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kscreen
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE's screen management software"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="ce47e5b0e16f985811d0e71d4c97d2d25d2a4258732c5b7b8706cdfd176c4883c431ea946833abcbc87fdd81ed6d546da6e23640b4586b8013591ee5917c20f0 kscreen-5.19.5.tar.xz"
+sha512sums="c8b8f87263f92cbf572497a717e20d4d85edc1ae9ac2dc01142dfd93bc048e09176485a0687baa7047af5dd23638afdcd05a0d3bf15a34a02d9c447fa0af473a kscreen-5.20.0.tar.xz"
diff --git a/community/kscreenlocker/APKBUILD b/community/kscreenlocker/APKBUILD
index b08c2ab0cd..0fd4d0aedc 100644
--- a/community/kscreenlocker/APKBUILD
+++ b/community/kscreenlocker/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kscreenlocker
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Library and components for secure lock screen architecture"
arch="all !armhf"
@@ -37,6 +37,6 @@ package() {
install -m644 "$srcdir"/kde-np.pam "$pkgdir"/etc/pam.d/kde-np
}
-sha512sums="aa112b28374e2ccfa257d161d47de96ba8a884dbf6cdc59be9dac3624e49472aad7ee0f413e63c9a001969b7e0413d2571e19f39e232e46cefe112fb7f880eda kscreenlocker-5.19.5.tar.xz
+sha512sums="229c81a41995205ba6b06c09d75f75d6eecdd5e0c8fbc428b0b411b1abafe14b9dc8e0e1afc5468e6c851d899fefca98b6d5bc8b0464a5e8f73ff291a14b1beb kscreenlocker-5.20.0.tar.xz
56e87d02d75c4a8cc4ed183faed416fb4972e7f223b8759959c0f5da32e11e657907a1df279d62a44a6a174f5aca8b2ac66a5f3325c5deb92011bcf71eed74c3 kde.pam
565265485dd7466b77966d75a56766216b8bcc187c95a997e531e9481cf50ddbe576071eb0e334421202bcab19aa6de6b93e042447ca4797a24bf97e1d053ffd kde-np.pam"
diff --git a/community/ksshaskpass/APKBUILD b/community/ksshaskpass/APKBUILD
index 662839a37b..c2e98d4541 100644
--- a/community/ksshaskpass/APKBUILD
+++ b/community/ksshaskpass/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ksshaskpass
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="ssh-add helper that uses kwallet and kpassworddialog"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -28,4 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="7bd70985cb4a133e49d58b27c9266222913097154b78f60fc55b7ea3e684723b3ae55cdd0b44f58dd7c2cb54cc2f6046907b7881355b437689d9e470c2aafdd4 ksshaskpass-5.19.5.tar.xz"
+sha512sums="a0e7cad3debde539da8432a84324a42f98206a2d5c22201dca89fe35dda15259eb5aa32ae20ded6c33b7db0b6ba4e4f44fa5b3ea703ecd3e7055e23005dcc563 ksshaskpass-5.20.0.tar.xz"
diff --git a/community/ksysguard/APKBUILD b/community/ksysguard/APKBUILD
index dd62b36a86..63e051b7c2 100644
--- a/community/ksysguard/APKBUILD
+++ b/community/ksysguard/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ksysguard
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Track and control the processes running in your system"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5dd3503e3792c247fa2dab274347ae00ac3ddd0090b8b5115abc90c84630e0f7376ce2ec43a853e2a9cfdadb31b142ea70190b54b65c7a45b5839b1dde5a1feb ksysguard-5.19.5.tar.xz"
+sha512sums="db3fa91c7b9c578766a4011ad8e60d9c0028189f8505d101e4f0cf8e1bf63e951adcb0feba3825696b33b1fa2c958c0e8ac08575b66c3d1a9258508a87af7178 ksysguard-5.20.0.tar.xz"
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index b7ffc0b8e9..8c5e2e3037 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwallet-pam
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KWallet PAM integration"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -23,4 +23,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="3fe30f979f6ee838b073b7afdb406068f90529fbbac3513d65145f6a46ab8ba0b61ba11a3e9192c60b1ddd50e9af448c1298725fc01dca483b40a8030053095d kwallet-pam-5.19.5.tar.xz"
+sha512sums="99c715222adb5c1d825981d2898528e01ee84887fd12e6cc9dfcab86edd5c3325a71bfb394d7d9e60f4cc1388d1e36410b34f579e2c840a121867787460f7b09 kwallet-pam-5.20.0.tar.xz"
diff --git a/community/kwayland-integration/APKBUILD b/community/kwayland-integration/APKBUILD
index 7e6766b45c..6ce93a59fb 100644
--- a/community/kwayland-integration/APKBUILD
+++ b/community/kwayland-integration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bhushan Shah <bshah@kde.org>
# Maintainer: Bhushan Shah <bshah@kde.org>
pkgname=kwayland-integration
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KWayland integration"
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -24,4 +24,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="db5f05ac9d942650b0933d723ba7138d35d262757b229f5f79b07a621543fdd87679da28d9fa059dc48064db39b69ce34f5296decdfc126442ac3f9f4bbbb2b6 kwayland-integration-5.19.5.tar.xz"
+sha512sums="088e59c0337bd6876802b3f2732d43c9f5120894eb2ecbf9364cd0e8638488d2bb4d9ed5487425ae274e10f14a2445b76dda2c229d5bf7f83ec9f7ab67ad334f kwayland-integration-5.20.0.tar.xz"
diff --git a/community/kwayland-server/APKBUILD b/community/kwayland-server/APKBUILD
index a36a9e18a0..12361a13a0 100644
--- a/community/kwayland-server/APKBUILD
+++ b/community/kwayland-server/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwayland-server
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Wayland Server Components built on KDE Frameworks"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -25,4 +25,4 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5e039e38f290daed747a4c5d0fb37c828ad7ff1e05b735abb30bfaa69d67e812ea89b78921ec0877622ed9127a92aa76b5c6468126004c0f53ddf909a45f391b kwayland-server-5.19.5.tar.xz"
+sha512sums="c5dab0a86e4a355294c9b2b793f4d0aa091d260abd85b7fe9523941792493c6cbce640e00957247996456acc8baca7ff4d42af84f5b30089844c8eb752fea4ba kwayland-server-5.20.0.tar.xz"
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 80da09888b..8eab31264b 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwin
-pkgver=5.19.5
-pkgrel=1
+pkgver=5.20.0
+pkgrel=0
pkgdesc="An easy to use, but flexible, composited Window Manager"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -36,4 +36,4 @@ package() {
# Remove CAP_SYS_NICE from kwin_wayland to make them work again
setcap -r "$pkgdir"/usr/bin/kwin_wayland
}
-sha512sums="97ad0096066d99b4bba3089416a6d3744b6f83d82a004caa8762b420cad34cac4221b3535678d4c6f1bcb43c4d97db56be5ac68c4ac501dc168f4472a6c0dad5 kwin-5.19.5.tar.xz"
+sha512sums="1565f2226b00706b02a20b3d49c9d14ee351bb47c183a3a0bd69d9662db802bd5b340eaa9817f5f01c07b3b0c60a10df32698b4605f8e0242c5fd5436307753a kwin-5.20.0.tar.xz"
diff --git a/community/kwrited/APKBUILD b/community/kwrited/APKBUILD
index 3b9c5fd022..40ac3635d7 100644
--- a/community/kwrited/APKBUILD
+++ b/community/kwrited/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kwrited
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE daemon listening for wall and write messages"
arch="all !armhf" # qt5-qtdeclarative-dev unavilable on armhf
@@ -23,4 +23,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c5beb32da7ea08d944d603db9f5af6356b7742be9408f8d5e540d2e782c54d0642f93a784420a931ce807f980fc6aed0135d54e8cb03f88831ac7c0404dc7136 kwrited-5.19.5.tar.xz"
+sha512sums="3bc33d0e1747042e3d2ab6c438b0fdf01e50073798b217f106e6d00d2b534322572f8263ef6b687c8f3d819b143431b59eaa473b17073dfb19d46e483d9174fb kwrited-5.20.0.tar.xz"
diff --git a/community/libkscreen/APKBUILD b/community/libkscreen/APKBUILD
index 2075d7063c..7eec0e610e 100644
--- a/community/libkscreen/APKBUILD
+++ b/community/libkscreen/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libkscreen
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE screen management software"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5bc462ee9e322bbdbd375003b962b868a6c6dfff6344e61d39e04644fbb7f409a337116df1c274a664f633b176dfd69af992d3e0e290fa85dbe529cbe1a1e87f libkscreen-5.19.5.tar.xz"
+sha512sums="d516cff6572abe02406451e71efc19749c42eb719f8506df492a462af1a3436ac16f4546ae974328572e0c169cc2a74e7bf055c5ab3c0de13729f9f254506ec1 libkscreen-5.20.0.tar.xz"
diff --git a/community/libksysguard/APKBUILD b/community/libksysguard/APKBUILD
index de7086e336..c8222a9cf7 100644
--- a/community/libksysguard/APKBUILD
+++ b/community/libksysguard/APKBUILD
@@ -1,13 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libksysguard
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE system monitor library"
arch="all !armhf"
url="https://www.kde.org/workspaces/plasmadesktop/"
license="LGPL-2.1-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
-depends_dev="qt5-qtwebchannel-dev kcoreaddons-dev kconfig-dev ki18n-dev kwindowsystem-dev kcompletion-dev kauth-dev kwidgetsaddons-dev kiconthemes-dev kconfigwidgets-dev kservice-dev kglobalaccel-dev kio-dev plasma-framework-dev zlib-dev knewstuff-dev"
+depends_dev="
+ kauth-dev
+ kcompletion-dev
+ kconfig-dev
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kglobalaccel-dev
+ ki18n-dev
+ kiconthemes-dev
+ kio-dev
+ knewstuff-dev
+ kservice-dev
+ kwidgetsaddons-dev
+ kwindowsystem-dev
+ plasma-framework-dev
+ qt5-qttools-dev
+ qt5-qtwebchannel-dev
+ zlib-dev
+ "
makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
source="https://download.kde.org/stable/plasma/$pkgver/libksysguard-$pkgver.tar.xz"
@@ -30,4 +48,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="8e723eff1e50195005a91dd558df0ddce956c33478c00e177f1eae4d9997ea8332d86bb8fae1eb2d18bfe3bdceefa31fe4211dfcf4bb1c463d347ced33e75348 libksysguard-5.19.5.tar.xz"
+sha512sums="8265461921a978c7ea202a577a3ad430b9ea6ea0479665ef11741ae89583c2bb7f58cb1aa82794b1badb4b3356f0305fa8d6efdbaddc6563bfceec099501dd28 libksysguard-5.20.0.tar.xz"
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index 0052155dff..11e2813414 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=milou
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="A dedicated search application built on top of Baloo"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -27,4 +27,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c480d22ec7f6be8031af13b23914add05d331b017c1d4d2a193a47f31cad1ede0bfa833a9368d0ba9c35cf5b0f97e23d15307ae45569d8bd9d7fde305d17b913 milou-5.19.5.tar.xz"
+sha512sums="b66e2f0437930b12e88bdd39df67c969b0a07fb54880cd76dd738e8b79b9aa993bbf3d80d04cce6bc9ef51e0b09853919bb38cff5dc606da74b99709cffb45eb milou-5.20.0.tar.xz"
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index 19b445af66..6bb87d6afe 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=oxygen
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -27,4 +27,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="53eec62c875dfb94d6b757e2b37b0ac23756d16ad4841cc6d7d9992cd2feaf8d7fba35987cd75f265563783dac013df509f7261033d169b8dca5e545e0eb03f4 oxygen-5.19.5.tar.xz"
+sha512sums="9a90a5e18932375955c1db1cfb29ec7a00bae3c7afbea27b47d13f53c614d760022d52bbc4114b5858b9d090be90c2cbe585e3026a53583039fc479ae0b0d185 oxygen-5.20.0.tar.xz"
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index bfd87ea2d3..8a0e6b7530 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-browser-integration
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -28,4 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c7334c4ab4ab3e0e1e93715257995fa7b16103a61eb40877b3e859f75b781e27456f96d5fef409284d0f584335f723b30a5a0bee0a06ffb9cea9012cb158b9e1 plasma-browser-integration-5.19.5.tar.xz"
+sha512sums="59184545c26f8592048b0473ac4852612fe59098bce8bf67d624e904c1d9d451a47ac7f27cfdabeec75bf0f9b7ac49be712acecd7286810cc7612f09bb20e2e3 plasma-browser-integration-5.20.0.tar.xz"
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index 503e36178d..bf8d1f9916 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE Plasma Desktop"
# s390x, mips, mips64 blocked by ibus
@@ -9,49 +9,57 @@ pkgdesc="KDE Plasma Desktop"
arch="all !s390x !armhf !mips !mips64"
url='https://www.kde.org/workspaces/plasmadesktop/'
license="GPL-2.0-only AND LGPL-2.1-only"
-depends="kirigami2 plasma-workspace setxkbmap qqc2-desktop-style ibus-emoji font-noto-emoji"
+depends="
+ font-noto-emoji
+ ibus-emoji
+ kirigami2
+ plasma-workspace
+ qqc2-desktop-style
+ setxkbmap
+ "
depends_dev="
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtx11extras-dev
- qt5-qtsvg-dev
+ attica-dev
+ baloo-dev
+ eudev-dev
+ fontconfig-dev
+ ibus-dev
+ kaccounts-integration-dev
+ kactivities-dev
+ kactivities-stats-dev
kauth-dev
- plasma-framework-dev
- ki18n-dev
kcmutils-dev
- knewstuff-dev
+ kconfig-dev
+ kdbusaddons-dev
+ kdeclarative-dev
kdelibs4support-dev
+ kemoticons-dev
+ kglobalaccel-dev
+ ki18n-dev
+ kitemmodels-dev
+ knewstuff-dev
knotifications-dev
knotifyconfig-dev
- attica-dev
- kwallet-dev
- krunner-dev
- kglobalaccel-dev
- kdeclarative-dev
kpeople-dev
- kdbusaddons-dev
- kactivities-dev
- kactivities-stats-dev
- kconfig-dev
- plasma-workspace-dev
+ krunner-dev
+ kwallet-dev
kwin-dev
- kitemmodels-dev
- kemoticons-dev
- baloo-dev
- fontconfig-dev
- eudev-dev
- xf86-input-libinput-dev
- xf86-input-evdev-dev
- xf86-input-synaptics-dev
- libxkbfile-dev
libxcursor-dev
libxi-dev
- ibus-dev
+ libxkbfile-dev
+ plasma-framework-dev
+ plasma-workspace-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ qt5-qtsvg-dev
+ qt5-qtx11extras-dev
+ xf86-input-evdev-dev
+ xf86-input-libinput-dev
+ xf86-input-synaptics-dev
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang knetattach"
+subpackages="$pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
build() {
@@ -81,4 +89,4 @@ knetattach() {
cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="d7c7b26dc5a7d4804a780833f8d22797312b845962ed4f9218c448fcb3c720c032eca1e79bec5f9c084f1825f0b6f26c34ffe032320396c9092e04a5b05c3d12 plasma-desktop-5.19.5.tar.xz"
+sha512sums="d34560977b75854a80cd75a9a15c9fed614ea9c36a724c2e5df9ae6e3439762a34d7afe33892beae2e7dff3fc555673f27069c43bb0bf774ad8740e3476be651 plasma-desktop-5.20.0.tar.xz"
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index 075fac2ec0..d053dd7454 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-integration
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
arch="all !armhf" # Blocked by qt5-qtdeclarative
@@ -32,4 +32,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="9e17e1720e5d5c1d3cada3f1eb891d27fd189eb65378c2e0be6547c79d93d5df2f785a3c67d35a4a374d320b118ad3b7d3fb7d968a7f5b629e505d21c83cfe36 plasma-integration-5.19.5.tar.xz"
+sha512sums="fd6d00e14bff37e14b407c9e6d6f5c1b4fe7a98218f714e8b79924862b8c1d0a83b367509a5924587f29f6ea5d1d8dc32643621e17ba01a0b682d2775653bbc3 plasma-integration-5.20.0.tar.xz"
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index 697e657155..400c34a68a 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nano
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="A minimal Plasma shell package intended for embedded devices"
arch="all !armhf"
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="0f9d2e3fb0c3e8920ab90ce8ebe0346cbe561bfb7cff9c6b70082b65257edf9d6305da85f8baaff23a85713fd4275ae69f67867459708957a1383a2a4ad3b56e plasma-nano-5.19.5.tar.xz"
+sha512sums="a42636ec134c6546309eb245e882debbf38d3984bc7d4721aa1d99cf84cf9a1ccd0fa6deb6bfd4c80cfb958bb3cd19b977900b5c390d818e0fbdb348572145d5 plasma-nano-5.20.0.tar.xz"
diff --git a/community/plasma-nm/APKBUILD b/community/plasma-nm/APKBUILD
index a565110f17..74040ed379 100644
--- a/community/plasma-nm/APKBUILD
+++ b/community/plasma-nm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-nm
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Plasma applet written in QML for managing network connections"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -9,9 +9,7 @@ url="https://www.kde.org/workspaces/plasmadesktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
depends="kirigami2 networkmanager"
makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev ki18n-dev kwindowsystem-dev kservice-dev kcompletion-dev kwidgetsaddons-dev kio-dev kcoreaddons-dev kwallet-dev kconfigwidgets-dev kiconthemes-dev solid-dev kdbusaddons-dev knotifications-dev plasma-framework-dev kdeclarative-dev qca-dev networkmanager-qt-dev modemmanager-qt-dev mobile-broadband-provider-info"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-nm-$pkgver.tar.xz
- fix-423093.patch
- "
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-nm-$pkgver.tar.xz"
subpackages="$pkgname-lang $pkgname-mobile"
build() {
@@ -46,5 +44,4 @@ mobile() {
"$pkgdir"/usr/share/kservices5/wifisettings.desktop \
"$subpkgdir"/usr/share/kservices5/
}
-sha512sums="2fdd42e7c9bba0b069e0ca39f8ef996b36a807a4065172a816023c32d5d24869bf92c577c9cc5a08bb9e8b13c628b7cbd8346d17dc1e6814c931f7f7ec9439a7 plasma-nm-5.19.5.tar.xz
-c5fc0ceee9ce3a512fc2ba7455704bfa5ba7d1e01df8b09d56f413ec3652e6689454c68cd3802c533932eb30c8fd2023b33afebe61fb8ef90bf501f806cb66b7 fix-423093.patch"
+sha512sums="db78e2c65a09cf6d77032c1a63ba0d66bac3946944a25f08f7267bfb776a39736189668ab3e2eaa815f09f0d7993bdc1384f9267e035053e40051b23a204d7f5 plasma-nm-5.20.0.tar.xz"
diff --git a/community/plasma-nm/fix-423093.patch b/community/plasma-nm/fix-423093.patch
deleted file mode 100644
index 243e69eddc..0000000000
--- a/community/plasma-nm/fix-423093.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Requested to backport by upstream to fix KDE bug 423093
-https://bugs.kde.org/show_bug.cgi?id=423093
-
-Has been merged upstream already and will be unnecessary with the
-release of the next full Plasma release
-
-From 271332cfc19ede398854113d037abfb35503179f Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Thu, 18 Jun 2020 15:34:40 +0000
-Subject: [PATCH] [WIP] [applet] Fix inline password field component not
- working properly
-
-BUG: 423093
-FIXED-IN: 5.20
----
- applet/contents/ui/ConnectionItem.qml | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/applet/contents/ui/ConnectionItem.qml b/applet/contents/ui/ConnectionItem.qml
-index 98240928..06c7ab25 100644
---- a/applet/contents/ui/ConnectionItem.qml
-+++ b/applet/contents/ui/ConnectionItem.qml
-@@ -231,8 +231,8 @@ PlasmaExtras.ExpandableListItem {
- if (!predictableWirelessPassword && !Uuid) {
- handler.addAndActivateConnection(DevicePath, SpecificPath)
- } else if (connectionItem.customExpandedViewContent == passwordDialogComponent) {
-- if (passwordDialogComponent.password != "") {
-- handler.addAndActivateConnection(DevicePath, SpecificPath, passwordDialogComponent.password)
-+ if (connectionItem.customExpandedViewContentItem.password != "") {
-+ handler.addAndActivateConnection(DevicePath, SpecificPath, connectionItem.customExpandedViewContentItem.password)
- connectionItem.customExpandedViewContent = detailsComponent
- connectionItem.collapse()
- } else {
---
-GitLab
-
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index 2cf7ad5e9c..dd3e17795e 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-pa
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="90d9faf8ab2f4fc7ecdc3e4fa84276ef6c7fc3abc2b2b7a0407e9f001c10330aa98a89ee68602c5378e4e46eec89a88c55e1e01dc2d755e613e4f584234331b6 plasma-pa-5.19.5.tar.xz"
+sha512sums="2440a8d0891d1c2dd3ac0b914f4de9b89a97d87b1ece8f2eaaeb2e28eaa9e0c6015392eed89f290ebc6fcc35805ce7c20d3b87c07dd1c99a186d3c7c1b476160 plasma-pa-5.20.0.tar.xz"
diff --git a/community/plasma-phone-components/APKBUILD b/community/plasma-phone-components/APKBUILD
index 780d91c56e..ef3e530443 100644
--- a/community/plasma-phone-components/APKBUILD
+++ b/community/plasma-phone-components/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-phone-components
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Modules providing phone functionality for Plasma"
arch="all !armhf"
url="https://www.plasma-mobile.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-depends="plasma-nano qt5-qtquickcontrols2 plasma-workspace dbus-x11 kactivities plasma-pa plasma-nm libqofono breeze-icons $pkgname-vkbd-style"
+depends="plasma-nano qt5-qtquickcontrols2 plasma-workspace dbus-x11 kactivities plasma-pa plasma-nm libqofono breeze-icons"
makedepends="extra-cmake-modules kpeople-dev qt5-qtdeclarative-dev kactivities-dev plasma-framework-dev kservice-dev kdeclarative-dev ki18n-dev kio-dev kcoreaddons-dev kconfig-dev kbookmarks-dev kwidgetsaddons-dev kcompletion-dev kitemviews-dev kjobwidgets-dev solid-dev kxmlgui-dev kconfigwidgets-dev kauth-dev kcodecs-dev kpackage-dev kwindowsystem-dev kdbusaddons-dev knotifications-dev kwayland-dev telepathy-qt-dev libphonenumber-dev"
-subpackages="$pkgname-lang $pkgname-vkbd-style:vkbd_style:noarch"
+subpackages="$pkgname-lang"
source="https://download.kde.org/stable/plasma/$pkgver/plasma-phone-components-$pkgver.tar.xz"
options="!check" # No tests
@@ -30,10 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-vkbd_style() {
- depends=""
- pkgdesc="Plasma Mobile style for Qt virtual keyboard"
-
- amove usr/lib/qt5/qml/QtQuick/VirtualKeyboard/Styles/Plasma
-}
-sha512sums="b29b6f77964cfc62d462aa089033b249bc1bdac0b108c770e4d92007d2cda42b126b8833f4c556f27180f3424612d489a75253f4d8ee75d0a6c012c8cc24d02b plasma-phone-components-5.19.5.tar.xz"
+sha512sums="88bc3a46279baddcde285bddf9695e884b635635c6c87fc12c88080ce623abcc58b6e41daa9f358c9a6300cce324274096fafa7fe79570ac0a40da1131b56698 plasma-phone-components-5.20.0.tar.xz"
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index 420b05a34a..3674b33011 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-sdk
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Applications useful for Plasma Development"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="66ca604bd27a7c48f8127f04e43c0093c098820e099c944cf7e4715ee0703175761ce6e4be270ffd78b0b1a87fbb2a8e7f670010df0032c4148bcf4275fc32f6 plasma-sdk-5.19.5.tar.xz"
+sha512sums="220f205930e9064ae74c3856db9f5075beaa9a8e24bd6bae485cdbca73f115ea21856e55522d5e1c729e981bf3242486b72a90299e79f859a7db746f774ae945 plasma-sdk-5.20.0.tar.xz"
diff --git a/community/plasma-thunderbolt/APKBUILD b/community/plasma-thunderbolt/APKBUILD
index f62f213402..15efd01de7 100644
--- a/community/plasma-thunderbolt/APKBUILD
+++ b/community/plasma-thunderbolt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-thunderbolt
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
arch="all !armhf !armv7" # Limited by bolt -> polkit, armhf also limited by qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
@@ -31,4 +31,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="34c0cb7495b03eaf4f84426fbb6ab2a8b3b336fa1a7f32014231f302c3f1a0e061462e32ded86dab713aa2b602ba5311da3a45e0352f63f59d6e503c1eb7905e plasma-thunderbolt-5.19.5.tar.xz"
+sha512sums="c99ff7a606e90b38ef10ce85c4adc375a4425b0d383db58829f8ccf61eeefa290c1f8a2c0b20b10b72af3bf607b4dea2ca0be98f0c6704fcb8e7247f32bfacab plasma-thunderbolt-5.20.0.tar.xz"
diff --git a/community/plasma-vault/APKBUILD b/community/plasma-vault/APKBUILD
index b954271523..4fb2f30ce2 100644
--- a/community/plasma-vault/APKBUILD
+++ b/community/plasma-vault/APKBUILD
@@ -1,16 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-vault
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Plasma applet and services for creating encrypted vaults"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only AND LGPL-3.0-only)"
makedepends="extra-cmake-modules qt5-qtbase-dev kactivities-dev kconfig-dev kconfigwidgets-dev kcoreaddons-dev kdbusaddons-dev ki18n-dev kio-dev plasma-framework-dev kwidgetsaddons-dev networkmanager-qt-dev libksysguard-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-vault-$pkgver.tar.xz
- fix-422684.patch
- "
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-vault-$pkgver.tar.xz"
subpackages="$pkgname-lang"
build() {
@@ -30,5 +28,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="d2c00601dae41b924ffb174a7fca9b508ff6e6ae052dd72fa2d9b6767718b4d40a25a7b7c9131f197d25e113c23d74df36829634ce8d83d4a76355aa66ce5771 plasma-vault-5.19.5.tar.xz
-4a89604861a494170c7c51e5fbec9320afda8dd16b76ec2ef6434bf7cbafc997890060ab8c576328b164017c45ac68c56129d2669cf590de280195bec99cdad6 fix-422684.patch"
+sha512sums="b16cdd8c40305d402bb378da12b48d39265150f06c10fc7e7b7415934fc10029fdbb21337b9605900a22780f26cea0592c092d3cd622a56ffae4d91b994f9992 plasma-vault-5.20.0.tar.xz"
diff --git a/community/plasma-vault/fix-422684.patch b/community/plasma-vault/fix-422684.patch
deleted file mode 100644
index 69d7439512..0000000000
--- a/community/plasma-vault/fix-422684.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Requested upstream to backport to fix KDE bug 422684
-https://bugs.kde.org/show_bug.cgi?id=422684
-
-This has been merged upstream and will be unnecessary from the next full
-Plasma release
-
-From f8f7179824f5540ee64900d20af39dfc9bacd490 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Sun, 14 Jun 2020 09:09:48 -0600
-Subject: [PATCH] Port applet to use PlasmaExtras.PlaceholderMessage
-
-The Kirigami version uses QQC2 elements which don't respect the plasma
-theme and color scheme, leading to thing slooking out of place
-especially when using a dark color theme or scheme.
-
-Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
----
- CMakeLists.txt | 6 ------
- plasma/package/contents/ui/main.qml | 4 +---
- 2 files changed, 1 insertion(+), 9 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e7aa0df..bc7c260 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -66,12 +66,6 @@ if (KF5NetworkManagerQt_FOUND)
- endif()
- find_package (KSysGuard REQUIRED)
-
--find_package(KF5Kirigami2 ${KF5_DEP_VERSION} CONFIG)
--set_package_properties(KF5Kirigami2 PROPERTIES
-- DESCRIPTION "A QtQuick based components set"
-- TYPE RUNTIME
--)
--
- include_directories (
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_SOURCE_DIR}/common
-diff --git a/plasma/package/contents/ui/main.qml b/plasma/package/contents/ui/main.qml
-index 22c7428..bfac7a9 100644
---- a/plasma/package/contents/ui/main.qml
-+++ b/plasma/package/contents/ui/main.qml
-@@ -26,8 +26,6 @@ import org.kde.plasma.plasmoid 2.0
- import org.kde.plasma.components 2.0 as PlasmaComponents
- import org.kde.plasma.extras 2.0 as PlasmaExtras
-
--import org.kde.kirigami 2.12 as Kirigami
--
- Item {
- property var vaultsModel: plasmoid.nativeInterface.vaultsModel
- property var vaultsModelActions: plasmoid.nativeInterface.vaultsModel.actionsModel()
-@@ -77,7 +75,7 @@ Item {
-
- interactive: false
-
-- Kirigami.PlaceholderMessage {
-+ PlasmaExtras.PlaceholderMessage {
- id: noVaultsMessage
-
- anchors.centerIn: parent
---
-GitLab
-
diff --git a/community/plasma-workspace-wallpapers/APKBUILD b/community/plasma-workspace-wallpapers/APKBUILD
index d87b2aa27c..60a6ed6f70 100644
--- a/community/plasma-workspace-wallpapers/APKBUILD
+++ b/community/plasma-workspace-wallpapers/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace-wallpapers
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Wallpapers for the Plasma Workspace"
arch="noarch !armhf" # armhf blocked by extra-cmake-modules
@@ -23,4 +23,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="79723d50f47412d4904effddbb641d75675a66f517e70164bf55f89e31cbb8246ea1617f90e4cd8e1c5ec169332187586443ead7bc2721b0df85a693ada9287f plasma-workspace-wallpapers-5.19.5.tar.xz"
+sha512sums="1e7f3d85f09572ccc613f8c6c6364a32b0c28a5a3843660daf6e96897a5867cec556dd9981c3607b7ea3e635716ad63b1b53400c6a09b777b30624d9e2a12ada plasma-workspace-wallpapers-5.20.0.tar.xz"
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index d22045487a..bc2f1e8419 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -1,20 +1,70 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-workspace
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="KDE Plasma Workspace"
arch="all !armhf" # armhf blocked by kirigami2 -> qt5-qtdeclarative
url="https://www.kde.org/workspaces/plasmadesktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-only"
-depends="tzdata qt5-qtquickcontrols kirigami2 kinit qt5-qttools kwin kactivitymanagerd milou plasma-integration qtchooser kded kquickcharts kio-extras"
-depends_dev="plasma-framework-dev krunner-dev kjsembed-dev knotifyconfig-dev kdesu-dev knewstuff-dev kwallet-dev kidletime-dev kdeclarative-dev ki18n-dev kcmutils-dev ktextwidgets-dev kdelibs4support-dev kcrash-dev kglobalaccel-dev kdbusaddons-dev kwayland-dev kcoreaddons-dev kded-dev libksysguard-dev kpackage-dev kscreenlocker-dev phonon-dev zlib-dev kitemmodels-dev networkmanager-qt-dev baloo-dev ktexteditor-dev kwin-dev kholidays-dev prison-dev kpeople-dev kactivities-stats-dev libkscreen-dev gpsd-dev iso-codes-dev"
+depends="
+ kactivitymanagerd
+ kded
+ kinit
+ kio-extras
+ kirigami2
+ kquickcharts
+ kwin
+ milou
+ plasma-integration
+ qt5-qtquickcontrols
+ qt5-qttools
+ qtchooser
+ tzdata
+ "
+depends_dev="
+ appstream-dev
+ baloo-dev
+ gpsd-dev
+ iso-codes-dev
+ kactivities-stats-dev
+ kcmutils-dev
+ kcoreaddons-dev
+ kcrash-dev
+ kdbusaddons-dev
+ kdeclarative-dev
+ kded-dev
+ kdelibs4support-dev
+ kdesu-dev
+ kglobalaccel-dev
+ kholidays-dev
+ ki18n-dev
+ kidletime-dev
+ kitemmodels-dev
+ kjsembed-dev
+ knewstuff-dev
+ knotifyconfig-dev
+ kpackage-dev
+ kpeople-dev
+ krunner-dev
+ kscreenlocker-dev
+ ktexteditor-dev
+ ktextwidgets-dev
+ kuserfeedback-dev
+ kwallet-dev
+ kwayland-dev
+ kwin-dev
+ libkscreen-dev
+ libksysguard-dev
+ networkmanager-qt-dev
+ phonon-dev
+ plasma-framework-dev
+ prison-dev
+ zlib-dev
+ "
makedepends="$depends_dev extra-cmake-modules kdoctools-dev libxtst-dev"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
- fix-422684.patch
- fix-with-gpsd-3.21.patch
- "
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-lang"
build() {
@@ -28,13 +78,11 @@ build() {
check() {
cd build
# nightcolortest requires running dbus
- # testdesktop is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(nightcolortest|testdesktop)"
+ # testdesktop, lookandfeel-kcmTest, test_kio_fonts and servicerunnertest are broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(nightcolortest|testdesktop|lookandfeel-kcmTest|test_kio_fonts|servicerunnertest)"
}
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="4cab64c1f817f391a61ae15e37bf1fc936ddd3fb3b234e281a3e5750b67dab05c1c156789446096cbde719bf972e876757c1c5ae78adde4e85f3591fa8df5df9 plasma-workspace-5.19.5.tar.xz
-43432f721c71698e094299c098129a5db769b6beeec8fee1a3a803fd081e9374c7d778b489fa7716ac4c3789a992722bc25f58b23fa0a06f65af38dc4d026ba9 fix-422684.patch
-60e8719759db29f8038d07ba335f293ca19a2da205f2cc7c297dcf98e7c291463db6d6911103ea136da128f1e0b75ef4b518757d1d8fe18c0e4e99914a241a43 fix-with-gpsd-3.21.patch"
+sha512sums="3b49ad852a1c2cfb1b4f304a25423506825b94ca80809e0e9ea55e1efa100b0b5411b3591087c35750f971e78dc640d851a367fae7c33902d02610d21511a613 plasma-workspace-5.20.0.tar.xz"
diff --git a/community/plasma-workspace/fix-422684.patch b/community/plasma-workspace/fix-422684.patch
deleted file mode 100644
index 1d71b2db21..0000000000
--- a/community/plasma-workspace/fix-422684.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Requested upstream to backport to fix KDE bug 422684
-https://bugs.kde.org/show_bug.cgi?id=422684
-
-This has been merged upstream and will be unnecessary from the next full
-Plasma release
-
-From faef126255222f727219bf69ac2b89857dc61ab2 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Sun, 14 Jun 2020 09:08:21 -0600
-Subject: [PATCH] Port applets to use PlasmaExtras.PlaceholderMessage
-
-The Kirigami version uses QQC2 elements which don't respect the plasma
-theme and color scheme, leading to thing slooking out of place
-especially when using a dark color theme or scheme.
-
-Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
----
- applets/clipboard/contents/ui/Menu.qml | 2 +-
- .../notifications/package/contents/ui/FullRepresentation.qml | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/applets/clipboard/contents/ui/Menu.qml b/applets/clipboard/contents/ui/Menu.qml
-index 0bd6064a5..cac8380db 100644
---- a/applets/clipboard/contents/ui/Menu.qml
-+++ b/applets/clipboard/contents/ui/Menu.qml
-@@ -55,7 +55,7 @@ PlasmaExtras.ScrollArea {
- onAction: menu.action(uuid)
- }
-
-- Kirigami.PlaceholderMessage {
-+ PlasmaExtras.PlaceholderMessage {
- id: emptyHint
-
- anchors.centerIn: parent
-diff --git a/applets/notifications/package/contents/ui/FullRepresentation.qml b/applets/notifications/package/contents/ui/FullRepresentation.qml
-index b34dee7af..989cb4341 100644
---- a/applets/notifications/package/contents/ui/FullRepresentation.qml
-+++ b/applets/notifications/package/contents/ui/FullRepresentation.qml
-@@ -585,7 +585,7 @@ PlasmaComponents3.Page {
- }
- }
-
-- Kirigami.PlaceholderMessage {
-+ PlasmaExtras.PlaceholderMessage {
- anchors.centerIn: parent
- width: parent.width - (units.largeSpacing * 4)
-
---
-GitLab
-
diff --git a/community/plasma-workspace/fix-with-gpsd-3.21.patch b/community/plasma-workspace/fix-with-gpsd-3.21.patch
deleted file mode 100644
index ab55379f1d..0000000000
--- a/community/plasma-workspace/fix-with-gpsd-3.21.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From e3134289f522edb140797818fffd60d641b86cd8 Mon Sep 17 00:00:00 2001
-From: Antonio Rojas <arojas@archlinux.org>
-Date: Wed, 5 Aug 2020 14:07:24 +0200
-Subject: [PATCH] Fix build with gpsd 3.21
-
-Adapt to API changes
----
- dataengines/geolocation/location_gps.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/dataengines/geolocation/location_gps.cpp b/dataengines/geolocation/location_gps.cpp
-index 021c29ac5..476117ca3 100644
---- a/dataengines/geolocation/location_gps.cpp
-+++ b/dataengines/geolocation/location_gps.cpp
-@@ -65,7 +65,11 @@ void Gpsd::run()
- if (m_gpsdata->online) {
- #endif
- //qDebug() << "online";
-+#if GPSD_API_MAJOR_VERSION >= 10
-+ if (m_gpsdata->fix.status != STATUS_NO_FIX) {
-+#else
- if (m_gpsdata->status != STATUS_NO_FIX) {
-+#endif
- //qDebug() << "fix";
- d["accuracy"] = 30;
- d["latitude"] = QString::number(m_gpsdata->fix.latitude);
-
diff --git a/community/plasma/APKBUILD b/community/plasma/APKBUILD
index 1f8ad89c72..49a347af43 100644
--- a/community/plasma/APKBUILD
+++ b/community/plasma/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Plasma (Base) meta package"
url="https://kde.org/plasma-desktop"
@@ -40,8 +40,7 @@ depends="
sddm-breeze
sddm-kcm
systemsettings
- udisks2
- user-manager
+ udisks2
xdg-desktop-portal-kde
xdg-user-dirs
"
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index b2a379230c..9b6b2820e9 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plymouth-kcm
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://cgit.kde.org/plymouth-kcm.git"
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="fbcebcec7ee4c69491b6425c5cac09801a26310ff15bc252bb66bdf8e322734c0d1551b97a4eb3e725e08e70010a0a4949560e2c5a58f61d1aa004620c8ac6cc plymouth-kcm-5.19.5.tar.xz"
+sha512sums="7a7444711adec1c48986a50d5dffddba4e399b5528c43bb2d94a9fc29cd76db16ae826ad765bf60157d0b8e866034e8e3d3e6b8fd3749373e6e591624520e088 plymouth-kcm-5.20.0.tar.xz"
diff --git a/community/polkit-kde-agent-1/APKBUILD b/community/polkit-kde-agent-1/APKBUILD
index b95a71054e..540f8e84df 100644
--- a/community/polkit-kde-agent-1/APKBUILD
+++ b/community/polkit-kde-agent-1/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=polkit-kde-agent-1
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Daemon providing a polkit authentication UI for KDE"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -29,4 +29,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f0e27056af864535c533a2bedbe2445f9e1648789150eac16031a1486f6676f8a4c929fee5f8cfbd7e48a904045f6c2d283083b33bbb823a2da27549d42090a5 polkit-kde-agent-1-5.19.5.tar.xz"
+sha512sums="6a3f3e642b8d420d5c1e1d4cfa42d02c03cd4659bf4524705b289227258f92d81a567afa870784e09b8ad70dc3c359f1e6200f1ee81f3e142f32e7707138b52c polkit-kde-agent-1-5.20.0.tar.xz"
diff --git a/community/powerdevil/APKBUILD b/community/powerdevil/APKBUILD
index cd42ff04cb..23aaf66abd 100644
--- a/community/powerdevil/APKBUILD
+++ b/community/powerdevil/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=powerdevil
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -30,4 +30,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5f1b1e8fdcd996769024a4f008527960fc91af32862047fdd13674ddb6925fd7b1a024a5c45182d14be32aa0bb8ba1bc694476061e480bcdfb3bdcb65d60cb16 powerdevil-5.19.5.tar.xz"
+sha512sums="09d0893ba0876fc7e1a90cde315cf3aefe3028b99fe3b7edd9fcf7f37b1552175b6514b9a49a68878497215d1ee73938c3efa8b63ddeb4e3be8aeb96b6d640c3 powerdevil-5.20.0.tar.xz"
diff --git a/community/sddm-kcm/APKBUILD b/community/sddm-kcm/APKBUILD
index 65f2281e03..959c0b8f73 100644
--- a/community/sddm-kcm/APKBUILD
+++ b/community/sddm-kcm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=sddm-kcm
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="Config module for SDDM"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -28,4 +28,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5eb79696addcb08e8c6eb95960a43cfd7ec5013a7948d67b025430fd09ad20917a71e903b5a2b0b0f1d47e7dbce7473cfa69dd143b9c6b2f4fbb8828cdd86704 sddm-kcm-5.19.5.tar.xz"
+sha512sums="57694ce045bb24d1cbf054140c8bc07cdf28adf81726951e542acaaa393d4d575da5a203878a1f0f86f528f5648d22dd12450e9ba954f2e60adaeda5df6a3cd6 sddm-kcm-5.20.0.tar.xz"
diff --git a/community/signond/APKBUILD b/community/signond/APKBUILD
index 55267b1b84..6f1bce79c1 100644
--- a/community/signond/APKBUILD
+++ b/community/signond/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=signond
pkgver=8.60
-pkgrel=0
+pkgrel=1
arch="all"
url="https://gitlab.com/accounts-sso/signond"
pkgdesc="A D-Bus service which performs user authentication on behalf of its clients"
@@ -19,7 +19,8 @@ builddir="$srcdir/$pkgname-VERSION_$pkgver"
build() {
qmake-qt5 \
PREFIX=/usr \
- LIBDIR=/usr/lib
+ LIBDIR=/usr/lib \
+ CONFIG+=rtti
make
}
diff --git a/community/systemsettings/APKBUILD b/community/systemsettings/APKBUILD
index 68af9b33c4..e9455c07bf 100644
--- a/community/systemsettings/APKBUILD
+++ b/community/systemsettings/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=systemsettings
-pkgver=5.19.5
+pkgver=5.20.0.1
pkgrel=0
pkgdesc="Plasma system manager for hardware, software, and workspaces"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -10,7 +10,7 @@ license="GPL-2.0-or-later"
depends="kirigami2"
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev kcrash-dev kitemviews-dev kcmutils-dev ki18n-dev kio-dev kservice-dev kiconthemes-dev kwidgetsaddons-dev kwindowsystem-dev kxmlgui-dev kdbusaddons-dev kconfig-dev kdoctools-dev kpackage-dev kdeclarative-dev kactivities-dev kactivities-stats-dev kirigami2-dev plasma-workspace-dev khtml-dev"
makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/stable/plasma/$pkgver/systemsettings-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/${pkgver%.*}/systemsettings-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
build() {
@@ -29,4 +29,4 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="381aa73e5bc195f2c05cf4df904a031f8415fffb99eaf33414604bdb623e8618c66ffa2e5b108b7838f5d9cb83cec578cefa4e414d9d7fa3fe258c864e1568fb systemsettings-5.19.5.tar.xz"
+sha512sums="01436f2e290355d83ba32d5f662fe4b39aa8856f6c2c202d84a516cb3cefce0c26a7162def8c70eafeb71d2e446c8e955b3cf42b2149ad653867171121940d16 systemsettings-5.20.0.1.tar.xz"
diff --git a/community/user-manager/APKBUILD b/community/user-manager/APKBUILD
deleted file mode 100644
index 9fc2bd5dfb..0000000000
--- a/community/user-manager/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=user-manager
-pkgver=5.19.5
-pkgrel=0
-pkgdesc="A simple system settings module to manage the users of your system"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
-url='https://www.kde.org/workspaces/plasmadesktop/'
-license="GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.0-or-later"
-makedepends="extra-cmake-modules qt5-qtbase-dev kwidgetsaddons-dev kcoreaddons-dev ki18n-dev kconfig-dev kconfigwidgets-dev kcmutils-dev kio-dev kiconthemes-dev kauth-dev libpwquality-dev"
-source="https://download.kde.org/stable/plasma/$pkgver/user-manager-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --build build --target install
-}
-sha512sums="de892a390f8843a4b81e5cb357fcab20b8fcb2a55f0dd83ce551a5eac3c07b80688af0a87ed44630827ebc1060b21371b19936a726f23cfb38fa298e8b162bd1 user-manager-5.19.5.tar.xz"
diff --git a/community/xdg-desktop-portal-kde/APKBUILD b/community/xdg-desktop-portal-kde/APKBUILD
index acb46a87e8..9ef6816a4c 100644
--- a/community/xdg-desktop-portal-kde/APKBUILD
+++ b/community/xdg-desktop-portal-kde/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=xdg-desktop-portal-kde
-pkgver=5.19.5
+pkgver=5.20.0
pkgrel=0
pkgdesc="A backend implementation for xdg-desktop-portal that is using Qt/KDE"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -9,9 +9,21 @@ arch="$arch !mips !mips64 !s390x" # xdg-desktop-portal->flatpak->polkit
url="https://phabricator.kde.org/source/xdg-desktop-portal-kde"
license="LGPL-2.0-or-later"
depends="xdg-desktop-portal"
-makedepends="extra-cmake-modules qt5-qtbase-dev glib-dev kio-dev kwayland-dev
- kdeclarative-dev kirigami2-dev kcoreaddons-dev plasma-framework-dev
- libepoxy-dev pipewire-dev kcoreaddons cups-dev"
+makedepends="
+ cups-dev
+ extra-cmake-modules
+ glib-dev
+ kcoreaddons-dev
+ kdeclarative-dev
+ kio-dev
+ kirigami2-dev
+ kwayland-dev
+ libepoxy-dev
+ pipewire-dev
+ plasma-framework-dev
+ plasma-wayland-protocols
+ qt5-qtbase-dev
+ "
subpackages="$pkgname-lang"
source="https://download.kde.org/stable/plasma/$pkgver/xdg-desktop-portal-kde-$pkgver.tar.xz"
@@ -27,4 +39,4 @@ package() {
DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="5d82e5a1553e9fcb471895e356a23915cbad1215ae1fff5fa6fac6f1673af4c406171131222a88a13eee847dc0d99f8bab00dac1849dfa6844b1672ae7545bb7 xdg-desktop-portal-kde-5.19.5.tar.xz"
+sha512sums="7aeee7085fc194c52c0a1d4b3c5c8569cc29cdda3dde8562e3ba57de1b205da68ce41234afcd916dba070c3d5643001183e2b5c6913b9f775d3a61f7808532e6 xdg-desktop-portal-kde-5.20.0.tar.xz"