aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/postfwd/APKBUILD (renamed from testing/postfwd2/APKBUILD)20
-rw-r--r--testing/postfwd/postfwd2.confd (renamed from testing/postfwd2/postfwd2.confd)0
-rw-r--r--testing/postfwd/postfwd2.initd (renamed from testing/postfwd2/postfwd2.initd)0
3 files changed, 11 insertions, 9 deletions
diff --git a/testing/postfwd2/APKBUILD b/testing/postfwd/APKBUILD
index 4254b19ab3b..a68cca55a65 100644
--- a/testing/postfwd2/APKBUILD
+++ b/testing/postfwd/APKBUILD
@@ -1,7 +1,6 @@
# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
-pkgname=postfwd2
-_pkgname=postfwd
+pkgname=postfwd
pkgver=1.39
pkgrel=0
pkgdesc="Combines complex postfix restrictions in a ruleset similar to those of the most firewalls"
@@ -10,14 +9,17 @@ arch="noarch"
license="BSD"
depends="perl-net-server perl-net-dns perl-io-multiplex"
subpackages="$pkgname-doc $pkgname-openrc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/v$pkgver.tar.gz
- $pkgname.initd
- $pkgname.confd
+source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
+ ${pkgname}2.initd
+ ${pkgname}2.confd
"
options="!check" # package has no tests
-builddir="$srcdir/$_pkgname-$pkgver"
-pkgusers="postfwd2"
-pkggroups="postfwd2"
+builddir="$srcdir/$pkgname-$pkgver"
+pkgusers="postfwd"
+pkggroups="postfwd"
+install="$pkgname.pre-install"
+provides="postfwd2=$pkgver-r$pkgrel" # for backward compatibility
+replaces="postfwd2" # for backward compatibility
build() {
cd "$builddir"
@@ -40,6 +42,6 @@ package() {
install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-sha512sums="b292b3d5cb634fedc039b33225e5f3e5653a25e56b5b2d9a5936d0a9d59ddb9a0fef129221f23859a679609eed57f4c7f20299f4895a48600cc78d2e22756a16 postfwd2-1.39.tar.gz
+sha512sums="b292b3d5cb634fedc039b33225e5f3e5653a25e56b5b2d9a5936d0a9d59ddb9a0fef129221f23859a679609eed57f4c7f20299f4895a48600cc78d2e22756a16 postfwd-1.39.tar.gz
b33ebb90d5e38f2af3cd93d0205672d83a618b253e22a6fc10cffee4b1e75513189f6214ae25a910913119c1ce0178fabdd95cc10c47ac1f85093953c4e04f5a postfwd2.initd
e1ead4e130c593fabf6ce28fdbdf74806bd922556b492976c03b3578112c533ca60645ad11786785763abf6dd94fee37f2e7261661314f712f9f46fad2acd20d postfwd2.confd"
diff --git a/testing/postfwd2/postfwd2.confd b/testing/postfwd/postfwd2.confd
index 7f16ef108bd..7f16ef108bd 100644
--- a/testing/postfwd2/postfwd2.confd
+++ b/testing/postfwd/postfwd2.confd
diff --git a/testing/postfwd2/postfwd2.initd b/testing/postfwd/postfwd2.initd
index 4206c8c01a5..4206c8c01a5 100644
--- a/testing/postfwd2/postfwd2.initd
+++ b/testing/postfwd/postfwd2.initd