aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/uchardet/APKBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/community/uchardet/APKBUILD b/community/uchardet/APKBUILD
index f0c1fea7c39..334bc4001b3 100644
--- a/community/uchardet/APKBUILD
+++ b/community/uchardet/APKBUILD
@@ -1,25 +1,17 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=uchardet
-pkgver=0.0.7
-pkgrel=1
+pkgver=0.0.8
+pkgrel=0
pkgdesc="Encoding detector library ported from Mozilla"
url="https://www.freedesktop.org/wiki/Software/uchardet"
arch="all"
license="MPL-1.1"
makedepends="cmake samurai"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-doc"
source="https://www.freedesktop.org/software/uchardet/releases/uchardet-$pkgver.tar.xz"
build() {
- case "$CARCH" in
- # Failing tests without SSE2 enabled
- # https://gitlab.freedesktop.org/uchardet/uchardet/-/issues/16
- x86)
- export CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse2"
- ;;
- esac
-
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -42,5 +34,5 @@ package() {
}
sha512sums="
-ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f uchardet-0.0.7.tar.xz
+4a5dcc9ff021352f3b252e103ff1475cec62c974294b264ee9243f024633c3ae44be8c7733608624066113e635f8b156ecb08c8ff87c736d04b07641eb166382 uchardet-0.0.8.tar.xz
"