aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/apache2-mod-realdoc/APKBUILD36
-rw-r--r--testing/apache2-mod-realdoc/mod-realdoc.conf1
2 files changed, 37 insertions, 0 deletions
diff --git a/testing/apache2-mod-realdoc/APKBUILD b/testing/apache2-mod-realdoc/APKBUILD
new file mode 100644
index 00000000000..1d789d5a069
--- /dev/null
+++ b/testing/apache2-mod-realdoc/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Keith <keithy@consultant.com>
+# Maintainer: Keith <keithy@consultant.com>
+pkgname=apache2-mod-realdoc
+pkgver=1
+pkgrel=1
+pkgdesc="Ensures realpath DocumentRoot for the whole request."
+url="https://github.com/etsy/mod_realdoc"
+docs="https://codeascraft.com/2013/07/01/atomic-deploys-at-etsy"
+arch="all"
+license="MIT"
+depends="apache2"
+makedepends="apache2-dev"
+options="!check"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/etsy/mod_realdoc/archive/f7fbf65256e7e843c42dee36517e6291b457643c.tar.gz
+ mod-realdoc.conf"
+builddir="$srcdir/mod_realdoc-f7fbf65256e7e843c42dee36517e6291b457643c"
+build() {
+ cd "$builddir"
+ apxs -c mod_realdoc.c
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+
+ # the install step used by rasmus
+ # apxs -i -n realdoc mod_realdoc.la
+
+ /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/build-1/libtool' mod_realdoc.la "$pkgdir"/usr/lib/apache2
+
+ install -D -m644 ../../mod-realdoc.conf "$pkgdir"/etc/apache2/conf.d/mod-realdoc.conf
+}
+
+sha512sums="f7ef7c80f150e5c497ee86df8aad47008797b22cc4315ea262f39c0e7f8f7cf9146c372bc170c013dc0d29892a0a51d872b07f2f119ff1ca0538a08f5f262fa4 apache2-mod-realdoc-1.tar.gz
+c317ac82433150a84cba3633ab0e55afe1f35ea1941e117a4760479b3d1ebbcaa1f081b36d198a381e30d699e3c028c7532c41dd53b3038c09a3401191f80b44 mod-realdoc.conf"
diff --git a/testing/apache2-mod-realdoc/mod-realdoc.conf b/testing/apache2-mod-realdoc/mod-realdoc.conf
new file mode 100644
index 00000000000..aa841110e76
--- /dev/null
+++ b/testing/apache2-mod-realdoc/mod-realdoc.conf
@@ -0,0 +1 @@
+LoadModule realdoc_module modules/mod_realdoc.so