aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/agl/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/agl/APKBUILD b/testing/agl/APKBUILD
new file mode 100644
index 00000000000..e4efe2a8f02
--- /dev/null
+++ b/testing/agl/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=agl
+pkgver=15
+pkgrel=0
+pkgdesc="Alpine Linux GitLab Manager"
+options="chmod-clean"
+url="https://gitlab.alpinelinux.org/Leo/agl"
+arch="all !mips64" # limited by go
+license="MIT"
+makedepends="go libgit2-dev"
+source="https://gitlab.alpinelinux.org/Leo/agl/-/archive/v$pkgver/agl-v$pkgver.tar.gz"
+builddir="$srcdir/agl-v$pkgver"
+
+build() {
+ go build -v -o agl -ldflags "-s -w"
+}
+
+check() {
+ go test -v ./...
+}
+
+package() {
+ install -Dm755 agl -t "$pkgdir"/usr/bin
+}
+
+sha512sums="0dbfecd3b8a14aa7473495455350377e8475a0249da39862762a3ec6fa711c5697fc7dbab5e4f7b343cf2a701694230d0f67d877a183f9a65258468471a61f88 agl-v15.tar.gz"