aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/jasper/APKBUILD28
-rw-r--r--main/jasper/disable-tests.patch15
-rw-r--r--main/jasper/rpath.patch25
3 files changed, 55 insertions, 13 deletions
diff --git a/main/jasper/APKBUILD b/main/jasper/APKBUILD
index dbcf70bfec2..ac90ae10c93 100644
--- a/main/jasper/APKBUILD
+++ b/main/jasper/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jasper
-pkgver=2.0.14
+pkgver=2.0.16
pkgrel=0
pkgdesc="A software-based implementation of the codec specified in the emerging JPEG-2000 Part-1 standard"
url="http://www.ece.uvic.ca/~mdadams/jasper/"
arch="all"
-license="custom:JasPer2.0"
-depends= #"libjpeg>=8 freeglut libxi libxmu mesa"
+license="JasPer-2.0"
makedepends="libjpeg-turbo-dev cmake"
+checkdepends="bash"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://www.ece.uvic.ca/~frodo/jasper/software/jasper-$pkgver.tar.gz
- "
-builddir="$srcdir"/$pkgname-$pkgver
+source="$pkgname-$pkgver.tar.gz::https://github.com/mdadams/jasper/archive/version-${pkgver}.tar.gz
+ rpath.patch
+ disable-tests.patch"
+builddir="$srcdir"/$pkgname-version-$pkgver
# secfixes:
# 2.0.12-r1:
@@ -28,15 +29,16 @@ build () {
make
}
-package() {
+check() {
cd "$builddir"/obj
- make DESTDIR="$pkgdir" install
+ make test
}
-libs() {
- pkgdesc="JPEG-2000 library"
- install -d "$subpkgdir"/usr/
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr
+package() {
+ cd "$builddir"/obj
+ make DESTDIR="$pkgdir" install
}
-sha512sums="9e5cffd2e899e37ba08890e2377ddfc3c2fb13d9fe00dea6b4612e4d241a6f4327de6835809b415c41ae4bf44208cf7871c1982ff5fc04ae6bc09fd376b0afc8 jasper-2.0.14.tar.gz"
+sha512sums="b3bca227f833567c9061c4a29c0599784ed6a131b5cceddfd1696542d19add821eda445ce6d83782b454b266723b24d0f028cbc644a25c0e3a75304e615b34ee jasper-2.0.16.tar.gz
+4fd85dda60412497ce9b9fc439cc78cc37216ea02bfcd00e2403d14be31f75c19532a31d45132ebb83dde3b31035277abb1b80bc523d9f7cb2f2018405997086 rpath.patch
+05ff28b58a68ee2b7b2aef5fcaeff3d81f9558e0353e43de2be7363c63243d8f79efc0994e2afe1ae0f391ae7bde3c84b252fa89f25ae87162c46f6f2d36f349 disable-tests.patch"
diff --git a/main/jasper/disable-tests.patch b/main/jasper/disable-tests.patch
new file mode 100644
index 00000000000..244aaf0103c
--- /dev/null
+++ b/main/jasper/disable-tests.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5f59d19..b439ce0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -399,9 +399,6 @@ if (BASH_PROGRAM)
+ add_test(run_test_2
+ "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+ "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_2")
+- add_test(run_test_3
+- "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+- "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_3")
+ add_test(run_test_4
+ "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+ "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_4")
+
diff --git a/main/jasper/rpath.patch b/main/jasper/rpath.patch
new file mode 100644
index 00000000000..322ff837de3
--- /dev/null
+++ b/main/jasper/rpath.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5f59d19..9208c65 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -340,19 +340,6 @@ endif()
+
+ if (JAS_ENABLE_SHARED)
+
+- # use, i.e. don't skip the full RPATH for the build tree
+- set(CMAKE_SKIP_BUILD_RPATH FALSE)
+-
+- # when building, don't use the install RPATH already
+- # (but later on when installing)
+- set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+-
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+-
+- # add the automatically determined parts of the RPATH
+- # which point to directories outside the build tree to the install RPATH
+- set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-
+ # The RPATH to be used when installing, but only if it's not a
+ # system directory
+ list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
+