aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/protobuf/APKBUILD6
-rw-r--r--main/protobuf/ruby-fix-cflags.patch17
2 files changed, 21 insertions, 2 deletions
diff --git a/main/protobuf/APKBUILD b/main/protobuf/APKBUILD
index 5e57881a9af..8615be969d5 100644
--- a/main/protobuf/APKBUILD
+++ b/main/protobuf/APKBUILD
@@ -4,7 +4,7 @@ pkgname=protobuf
_gemname=google-protobuf
pkgver=3.11.2
_tstver=5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081
-pkgrel=0
+pkgrel=1
pkgdesc="Library for extensible, efficient structure packing"
url="https://github.com/google/protobuf"
arch="all"
@@ -28,6 +28,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/google/protobuf/archive/v$pk
googletest-$_tstver.tar.gz::https://github.com/google/googletest/archive/$_tstver.tar.gz
musl-fix.patch
trim-rakefile.patch
+ ruby-fix-cflags.patch
"
prepare() {
@@ -150,4 +151,5 @@ dev() {
sha512sums="8319c1e003e5fc64e91b512de016ec1cf10265b294d3b4beea60856beaeb02b4d7682343c74b2c12b0f6d4d6258451af9b9d72bcb4b495293b7637da21030c8f protobuf-3.11.2.tar.gz
623b077b3334958fafcbc34aa85891883277994af33be530efd903f47738a3e3562001cbf3b6da1a5e7d03803c5bd51bcc1fab81490db85d5a4f2b15e7de1495 googletest-5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081.tar.gz
875592bc5dc5efe9087ea1b340673f54c984ecd5aa3b110a2da136bdc28009af7ce1a9c57f4747ff809fc02eb6c39a0209c277177172af467a54172d9700188a musl-fix.patch
-495ba43f1e43e49caee6f44bb7e8e1cc52d46b158b946598c2b296a9efa07fd9abadc8649c3751aad34d26380dcdef782239449cbc5fd7654df144d249dd9de2 trim-rakefile.patch"
+495ba43f1e43e49caee6f44bb7e8e1cc52d46b158b946598c2b296a9efa07fd9abadc8649c3751aad34d26380dcdef782239449cbc5fd7654df144d249dd9de2 trim-rakefile.patch
+e2063bfb3f323625449d71cc2fe91e848a93af50cb1688ec5635bb1088aacd17a3282b0e91e05109abcc5fdbd62dff88f2b90bb78273b24f98998ed0009b1170 ruby-fix-cflags.patch"
diff --git a/main/protobuf/ruby-fix-cflags.patch b/main/protobuf/ruby-fix-cflags.patch
new file mode 100644
index 00000000000..690868d1ea7
--- /dev/null
+++ b/main/protobuf/ruby-fix-cflags.patch
@@ -0,0 +1,17 @@
+This fixes problem with missing symbol __va_copy, see
+https://github.com/protocolbuffers/protobuf/pull/6848.
+
+--- a/ruby/ext/google/protobuf_c/extconf.rb
++++ b/ruby/ext/google/protobuf_c/extconf.rb
+@@ -3,9 +3,9 @@
+ require 'mkmf'
+
+ if RUBY_PLATFORM =~ /darwin/ || RUBY_PLATFORM =~ /linux/
+- $CFLAGS += " -std=gnu90 -O3 -DNDEBUG -Wall -Wdeclaration-after-statement -Wsign-compare"
++ $CFLAGS += " -std=gnu99 -DNDEBUG -Wall -Wdeclaration-after-statement -Wsign-compare"
+ else
+- $CFLAGS += " -std=gnu90 -O3 -DNDEBUG"
++ $CFLAGS += " -std=gnu99 -DNDEBUG"
+ end
+
+