aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mpc/APKBUILD9
-rw-r--r--community/mpc/doc-py3.patch14
2 files changed, 20 insertions, 3 deletions
diff --git a/community/mpc/APKBUILD b/community/mpc/APKBUILD
index ba4c0d6d036..77aa86594a9 100644
--- a/community/mpc/APKBUILD
+++ b/community/mpc/APKBUILD
@@ -7,9 +7,11 @@ pkgdesc="Minimalist command line interface to MPD"
url="https://www.musicpd.org/clients/mpc/"
arch="all"
license="GPL-2.0-or-later"
-makedepends="libmpdclient-dev py-sphinx meson check-dev"
+makedepends="libmpdclient-dev py3-sphinx meson check-dev"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
-source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ doc-py3.patch
+ "
build() {
meson \
@@ -41,4 +43,5 @@ bashcomp() {
"$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
-sha512sums="1913249da8b29123005a9877ff2e68f9469f8fd48f5411ea0e651255c93fbe14ef6029dadc7d256a99b566085dc19f4c62bdcf55260b27de3d088b8e9c17fcde mpc-0.32.tar.xz"
+sha512sums="1913249da8b29123005a9877ff2e68f9469f8fd48f5411ea0e651255c93fbe14ef6029dadc7d256a99b566085dc19f4c62bdcf55260b27de3d088b8e9c17fcde mpc-0.32.tar.xz
+7be9a58480b5b7b78e411272aa1ccc996e3c837b954c14cfed9cbed31897ae0c34afc4fad5e7dc7ad194dc6e24cebcff7e063610db73f94327de4c9656a946c5 doc-py3.patch"
diff --git a/community/mpc/doc-py3.patch b/community/mpc/doc-py3.patch
new file mode 100644
index 00000000000..6f696587279
--- /dev/null
+++ b/community/mpc/doc-py3.patch
@@ -0,0 +1,14 @@
+diff --git a/meson.build b/meson.build
+index d919bc3..3390fb5 100644
+--- a/meson.build
++++ b/meson.build
+@@ -126,7 +126,7 @@ endif
+
+ with_documentation = get_option('documentation')
+ if not with_documentation.disabled()
+- sphinx = find_program('sphinx-build', required: with_documentation)
++ sphinx = find_program('sphinx-build-3', required: with_documentation)
+ if sphinx.found()
+ subdir('doc')
+ endif
+