aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/emulationstation/APKBUILD4
-rw-r--r--testing/emulationstation/gcc12.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/testing/emulationstation/APKBUILD b/testing/emulationstation/APKBUILD
index 90d1a7593ac..064d314f980 100644
--- a/testing/emulationstation/APKBUILD
+++ b/testing/emulationstation/APKBUILD
@@ -3,7 +3,7 @@
pkgname=emulationstation
_pkgname="EmulationStation"
pkgver=2.10.3
-pkgrel=3
+pkgrel=4
pkgdesc="EmulationStation is a cross-platform graphical front-end for emulators with controller navigation."
url="https://github.com/RetroPie/EmulationStation"
arch="all !armhf !s390x !riscv64" # vlc-dev
@@ -19,6 +19,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/RetroPie/$_pkgname/archive/v
$pkgname-theme-$_theme_name-$_theme_commit.tar.gz::https://github.com/rxbrad/es-theme-$_theme_name/archive/$_theme_commit.tar.gz
pugixml-$_pugixml_ver.tar.gz::https://github.com/zeux/pugixml/archive/v$_pugixml_ver.tar.gz
default-paths.patch
+ gcc12.patch
emulationstation.desktop
emulationstation.png"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -63,6 +64,7 @@ sha512sums="
23e764e41a8ca359657508f5103c841e25d6403ddaafa9ca2f55379e42a17541d85cacac9d18fa9316d17450cd6bd6b8ae345f07165971b2a02e03b8e33bf35c emulationstation-theme-gbz35-05895874b2920ab6ffeeb574d053f3d9e976c000.tar.gz
94a79a28d96e763cdd8951c4d0b20aefb43cd1b32cbf5a5354b09f2636710e960e2dbfa56534b61c8d6ddecb2126a006e5f485c1465a97376e1cc077df25f16e pugixml-1.11.1.tar.gz
f97954e411078507b312b9859ff300bf2018945dedc2be593103a0aca1b0bd233a173ab6f74c983735bf0bbc0600b49ba6987b60c03ed697c1328f906c154799 default-paths.patch
+6d156df98bef5c7ceef115e0c89ee986b16e47d82072b46c7b70d93556d4a7bc62f921f3b05a6f7eb903acd09927538538ecb923617abc5e644e368e44ec63a9 gcc12.patch
814a196d234266809f2c3f64c7179e3138e017eb67d1c54dcc2e8c504c1439cb73f17352575cd582ce044b08405f3a369d049127c9f4c5a1336072435dfa54f0 emulationstation.desktop
4a24c435aeef22d7d69c3af113bff97c2c99b4a1eb2e5c97f53a6cce1f11a4f92bf4250388598a89f8fd462e03ea6fc73b75739573faf6f7b30c98ab53ddb5bf emulationstation.png
"
diff --git a/testing/emulationstation/gcc12.patch b/testing/emulationstation/gcc12.patch
new file mode 100644
index 00000000000..0a1aa3031ac
--- /dev/null
+++ b/testing/emulationstation/gcc12.patch
@@ -0,0 +1,12 @@
+diff --git a/es-core/src/utils/TimeUtil.h b/es-core/src/utils/TimeUtil.h
+index 9b44207..db69ad3 100644
+--- a/es-core/src/utils/TimeUtil.h
++++ b/es-core/src/utils/TimeUtil.h
+@@ -2,6 +2,7 @@
+ #ifndef ES_CORE_UTILS_TIME_UTIL_H
+ #define ES_CORE_UTILS_TIME_UTIL_H
+
++#include <ctime>
+ #include <string>
+
+ namespace Utils