aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/boost/APKBUILD10
-rw-r--r--main/boost/boost-fiber-mips64-ftbfs.patch13
2 files changed, 4 insertions, 19 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index a0698bec355..71f5c1b57df 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=boost
-pkgver=1.72.0
+pkgver=1.75.0
_pkgver="${pkgver//./_}"
-pkgrel=6
+pkgrel=0
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="https://www.boost.org/"
arch="all"
@@ -15,7 +15,6 @@ source="https://dl.bintray.com/boostorg/release/$pkgver/source/boost_$_pkgver.ta
boost-1.57.0-python-abi_letters.patch
boost-1.57.0-python-libpython_dep.patch
0001-revert-cease-dependence-on-range.patch
- boost-fiber-mips64-ftbfs.patch
"
builddir="$srcdir/${pkgname}_$_pkgver"
@@ -176,8 +175,7 @@ _pyversion() {
"$1" -c 'import sys; print("%i.%i" % (sys.version_info.major, sys.version_info.minor))'
}
-sha512sums="63bbd1743e7c904b2e69fdc2eafd1c2a8a30fd70d960dcd366059d0100f000cb605d56cbd9397bb18421631f1c9552a772c434d0f0caddbe56302273f51fd1f6 boost_1_72_0.tar.bz2
+sha512sums="4ec9c1164ec9b95ce46ba1c073e586c94b3882dce5b7347ea14bbef0c1da230e12aa5328a501ce38cae1b1d7623daa3246325625899179b4cc309242540982a4 boost_1_74_0.tar.bz2
d96d4d37394a31764ed817d0bc4a99cffa68a75ff1ecfd4417b9e1e5ae2c31a96ed24f948c6f2758ffdac01328d2402c4cf0d33a37107e4f5f721e636daebd66 boost-1.57.0-python-abi_letters.patch
132c4b62815d605c2d3c9038427fa4f422612a33711d47b2862f2311516af8a371d6b75bf078a7bffe20be863f8d21fb9fe74dc1a1bac3a10d061e9768ec3e02 boost-1.57.0-python-libpython_dep.patch
-9b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch
-054f475a3a89d550c374a0a80cda580adf5d12e75a44166c9cddf7247e603285c85b428c3c799f00cdd8e4af3fc690d9cef05320ac2fbf2a07dae9827d4bd647 boost-fiber-mips64-ftbfs.patch"
+9b53d2fe2dddd592e43db03c26fadd6c07d4c45a980ae4c775b7a914346a3914f6e0c3ef42dad5e2ea4568afb86c9967e09444ff609cfba1e1d39f4980b22ad6 0001-revert-cease-dependence-on-range.patch"
diff --git a/main/boost/boost-fiber-mips64-ftbfs.patch b/main/boost/boost-fiber-mips64-ftbfs.patch
deleted file mode 100644
index bde053ff7f9..00000000000
--- a/main/boost/boost-fiber-mips64-ftbfs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Roughly equivalent to upstream 5f7cda29add367c5381775a314ec9f90e311457a.
-
---- a/boost/fiber/detail/cpu_relax.hpp
-+++ b/boost/fiber/detail/cpu_relax.hpp
-@@ -47,7 +47,7 @@ namespace detail {
- # else
- # define cpu_relax() asm volatile ("nop" ::: "memory");
- # endif
--#elif BOOST_ARCH_MIPS
-+#elif BOOST_ARCH_MIPS && (__mips_isa_rev > 1)
- # define cpu_relax() asm volatile ("pause" ::: "memory");
- #elif BOOST_ARCH_PPC
- // http://code.metager.de/source/xref/gnu/glibc/sysdeps/powerpc/sys/platform/ppc.h