aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/podman/APKBUILD15
-rw-r--r--community/podman/podman.confd6
-rw-r--r--community/podman/podman.initd6
3 files changed, 13 insertions, 14 deletions
diff --git a/community/podman/APKBUILD b/community/podman/APKBUILD
index 69b5be2a475..890660ed5fc 100644
--- a/community/podman/APKBUILD
+++ b/community/podman/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=podman
-pkgver=3.1.2
-pkgrel=1
+pkgver=3.2.0
+pkgrel=0
pkgdesc="Simple management tool for pods, containers, and images"
url="https://podman.io/"
license="Apache-2.0"
@@ -81,9 +81,6 @@ docker() {
install -d "$subpkgdir"/usr/bin
make PREFIX=/usr DESTDIR="$subpkgdir" install.docker
- install -d "$subpkgdir"/run
- ln -s /run/podman/podman.sock "$subpkgdir"/run/docker.sock
-
# Remove man pages
rm -rf "$subpkgdir"/usr/share
@@ -106,6 +103,8 @@ docker_doc() {
done
}
-sha512sums="fdc26368f3cce6a11fe9adeae34a2f04396a554bb5f245e07fc98d1ce21dff66faba5549e9e0b94793d67768ff03fea2990e7a2759dd41ed2b72778431f5dd9d podman-3.1.2.tar.gz
-279e3587bf264607402c60130662d192924d2f90f2ebc7b1dc673fd119722ad07eac29658da137afa68af2c1f338680c33709866a8c677a79f87763c4dfca756 podman.initd
-77c71f3d07fa87da5b947287ef9a281eb1764b2682886a214333d910f95b1601d15c3dd0351bbb23ec38f96fc56c8d4196f44b73c01be05088829a02b925c4ca podman.confd"
+sha512sums="
+7db6145e5b303b29b600e9393d0d872931bbe39c385c4e9904b59b1b9a9b87f0191374cc8a13e021d4446c31e461f7be3765c2d18bcb8461df732c89fc848c96 podman-3.2.0.tar.gz
+72e91da5c2144c190f4f1a98b5b1f32cbaee50ef53d4c0a2a255a514b79d76cf71a1eca9470d4ad0a5f51ee65df68b1711fd7c5b90a416916715c607275af484 podman.initd
+ec6e6d3f72d0ab6c90a30b2cca5152c0d0f1e402ae671289263d7bf3b5141de9d67c3593f20b6075cedd214b7fb1506e69ff7b4f9691b43b391389343ab9b9b1 podman.confd
+"
diff --git a/community/podman/podman.confd b/community/podman/podman.confd
index 6bce300664e..5d75790cfa8 100644
--- a/community/podman/podman.confd
+++ b/community/podman/podman.confd
@@ -2,11 +2,11 @@
# See podman-system-service(1) for service description
# and available options.
-podman_opts="--time=0" # do not expire service session
+#podman_opts="--time 0"
# API endpoint in URI form. Leave empty to use defaults.
-podman_uri=""
+#podman_uri=""
# Setting root user will start rootful service.
# Use any other user for rootless mode.
-podman_user="root"
+#podman_user="root"
diff --git a/community/podman/podman.initd b/community/podman/podman.initd
index d600b56d174..4a016d6f565 100644
--- a/community/podman/podman.initd
+++ b/community/podman/podman.initd
@@ -5,11 +5,11 @@ name="Podman API service"
description="Listening service that answers API calls for Podman"
command=/usr/bin/podman
-command_args="system service $podman_opts $podman_uri"
-command_user="${podman_user:-root}"
+command_args="system service ${podman_opts:=--time 0} $podman_uri"
+command_user="${podman_user:=root}"
depend() {
- need sysfs cgroups
+ need sysfs cgroups
}
start_pre() {