aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/darktable/APKBUILD6
-rw-r--r--community/darktable/fix-cmake-none.patch16
2 files changed, 11 insertions, 11 deletions
diff --git a/community/darktable/APKBUILD b/community/darktable/APKBUILD
index 209cc74ee60..88bc6cd30ee 100644
--- a/community/darktable/APKBUILD
+++ b/community/darktable/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=darktable
-pkgver=3.0.1
+pkgver=3.0.2
pkgrel=0
pkgdesc="an open source photography workflow application and raw developer"
url="https://www.darktable.org/"
@@ -64,6 +64,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="a01830c5177512fb7b59f07a5ac594b486f854d41e7123faa0252caef52386ef3df4896f2c23a61b57a2b9b7bec33f3fd2f1fce6cea1388e1b74056a159e7ffa darktable-3.0.1.tar.xz
+sha512sums="ee2d83f60621586f9e1be958f4b0c3d2214fbf30338837dbd07b901641c32d565cd29f814f5ff75a450495acee2383aa62ba3da3873009077704c925bab501f1 darktable-3.0.2.tar.xz
bbb665f06b21a75f34a82f26d9e7421281445843b392871d1f851c7b73eabc862bbe43525b669a67429a22fea63bb03ca90b8a1d200d62a52907946ffcd9a7e3 fix-ifunc-multiarch.patch
-62e7214fb8cadd5f7d994283c684e39052ccfb020861852126dd4af8b071c406a57a08580b0d3415e1e12634b1e88af9c29da420e2f58edb57849db0d4954b29 fix-cmake-none.patch"
+74a47de2820e34d5c4ac53adbc557be908f73c06ab7e978429b22a5decb9c974871f5a83a23dd4fe6a7c13bc54de65ef004776efda8aad3f38d27fb35c0bd2c6 fix-cmake-none.patch"
diff --git a/community/darktable/fix-cmake-none.patch b/community/darktable/fix-cmake-none.patch
index 6cacc140b81..d005e1db348 100644
--- a/community/darktable/fix-cmake-none.patch
+++ b/community/darktable/fix-cmake-none.patch
@@ -1,13 +1,13 @@
diff --git a/src/external/rawspeed/cmake/build-type.cmake b/src/external/rawspeed/cmake/build-type.cmake
-index c04263c..c72f7cb 100644
+index 4c15761..f752d1b 100644
--- a/src/external/rawspeed/cmake/build-type.cmake
+++ b/src/external/rawspeed/cmake/build-type.cmake
-@@ -19,7 +19,7 @@ endif(NOT CMAKE_BUILD_TYPE)
+@@ -17,7 +17,7 @@ if(NOT CMAKE_BUILD_TYPE)
+ SET(CMAKE_BUILD_TYPE ${default_build_type} CACHE STRING "" FORCE)
+ endif(NOT CMAKE_BUILD_TYPE)
- # yes, these build types need to be specified here in upper-case.
- set(SPECIAL_BUILD_TYPES COVERAGE SANITIZE TSAN FUZZ)
--set(CMAKE_CONFIGURATION_TYPES DEBUG RELWITHDEBINFO RELEASE ${SPECIAL_BUILD_TYPES})
-+set(CMAKE_CONFIGURATION_TYPES DEBUG RELWITHDEBINFO RELEASE NONE ${SPECIAL_BUILD_TYPES})
- set(CMAKE_CONFIGURATION_TYPES "${CMAKE_CONFIGURATION_TYPES}" CACHE STRING "All the available build types" FORCE)
+-set(RAWSPEED_STANDARD_BUILD_TYPES Debug RelWithDebInfo Release)
++set(RAWSPEED_STANDARD_BUILD_TYPES Debug RelWithDebInfo Release None)
+ set(RAWSPEED_SPECIAL_BUILD_TYPES Coverage Sanitize TSan Fuzz)
+ set(CMAKE_CONFIGURATION_TYPES ${RAWSPEED_STANDARD_BUILD_TYPES} ${RAWSPEED_SPECIAL_BUILD_TYPES} CACHE STRING "All the available build types" FORCE)
- string(TOUPPER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE)