aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/pass/APKBUILD5
-rw-r--r--community/pass/fix-password-generation.patch16
2 files changed, 20 insertions, 1 deletions
diff --git a/community/pass/APKBUILD b/community/pass/APKBUILD
index dda5c544158..e70158a9164 100644
--- a/community/pass/APKBUILD
+++ b/community/pass/APKBUILD
@@ -1,9 +1,10 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=pass
pkgver=1.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Stores, retrieves, generates, and synchronizes passwords securely"
url="https://www.passwordstore.org"
arch="noarch"
@@ -16,6 +17,7 @@ subpackages="$pkgname-doc
$pkgname-fish-completion:fishcomp
$pkgname-zsh-completion:zshcomp"
source="https://git.zx2c4.com/password-store/snapshot/password-store-$pkgver.tar.xz
+ fix-password-generation.patch
README.alpine
"
builddir="$srcdir/password-store-$pkgver"
@@ -70,4 +72,5 @@ zshcomp() {
}
sha512sums="89755a7b02f05d75055a9fc14fd3f456c0a49ec31bdffd097a027f91228c64a98b18c1e80017aeda811773ae3287ff1b9737532da8ded06799d8fe3979ca06f7 password-store-1.7.3.tar.xz
+fb2d78975041197f5e9ace5dc2ac8f2de46ebd43ca08c65a527c8c5e5128f0e6baa64a7d994c393777b8a6ddf987f275f815db11359bb787faa89875a508c291 fix-password-generation.patch
eca180d02af608b18a2b6d4b0eaa685c9b1bb8d2ccde921fb27cc12d6d4c31551c6b69fc2ddd2baaa840630ba3c8c0c44ee40b612e8dc004c2b90aafd299a4fa README.alpine"
diff --git a/community/pass/fix-password-generation.patch b/community/pass/fix-password-generation.patch
new file mode 100644
index 00000000000..53abcebf77d
--- /dev/null
+++ b/community/pass/fix-password-generation.patch
@@ -0,0 +1,16 @@
+Upstream: https://git.zx2c4.com/password-store/commit/?id=c22cdbd4674a25dec71fe42ec1ef0b4829b6c7f3
+Reason: See the commit for explanation
+
+diff --git a/src/password-store.sh b/src/password-store.sh
+index b99460c..1d119f2 100755
+--- a/src/password-store.sh
++++ b/src/password-store.sh
+@@ -17,7 +17,7 @@ EXTENSIONS="${PASSWORD_STORE_EXTENSIONS_DIR:-$PREFIX/.extensions}"
+ X_SELECTION="${PASSWORD_STORE_X_SELECTION:-clipboard}"
+ CLIP_TIME="${PASSWORD_STORE_CLIP_TIME:-45}"
+ GENERATED_LENGTH="${PASSWORD_STORE_GENERATED_LENGTH:-25}"
+-CHARACTER_SET="${PASSWORD_STORE_CHARACTER_SET:-[:graph:]}"
++CHARACTER_SET="${PASSWORD_STORE_CHARACTER_SET:-[:punct:][:alnum:]}"
+ CHARACTER_SET_NO_SYMBOLS="${PASSWORD_STORE_CHARACTER_SET_NO_SYMBOLS:-[:alnum:]}"
+
+ export GIT_CEILING_DIRECTORIES="$PREFIX/.."